Very Long Saving Time with Large Project

Hi there,
I am working on a large choral symphonic project and when I save it, it takes 1 minute (yes, I stopped watched it :wink: ) for me to be able to continue working on that dorico file.
My question: Can there be other reasons for being so slow than the size of the project and the speed of my computer?

Here are the facts about the .dorico file.
31 flows
10 woods (some of the doubling, like 2nd flute + picc.)
10 brass
timpani
2 percussion players with 8 instruments each
3 solo vocalists
SATB choir
Guitar
Piano
Accordion
Strings

My computer
MacBook Pro
Intel Core i7-4870HQ (4x 2,5 GHz / 6 MB Cache)
16 GB Ram

I would be very grateful for any help, since this is very annoying.

Best regards from Germany, Axel

Here is something to try: in Setup mode, create a new Full Score layout (at the bottom of the right-hand panel). In this new layout, uncheck any flows you’re not working on at the moment.

Then, you will be able to work on that particular flow, without Dorico calculating page view etc. for all the 30 other flows.

In my experience this works well for composing. But for final editing, page turns, and stuff like that in Engrave mode, you may be better off working on the whole score, with long edit and save times. With big projects like this, I don’t know of other solutions, but I’m interested in other people’s ideas.

1 Like

Where are you saving the file? Locally, cloud storage or network storage?

What playback template are you using, what VSTs are you using, and have you done considerable manual work on playback?

What is the file size (in kilobytes/megabytes)?

I save the file locally.

I haven’t changed the playback template, i.e. I’m using the default one, and no, I haven’t done any manual work on playback - maybe a few notes in the past.

The file size is 19,6 MB.

19.6 MB seems like a very big size for a Dorico file. The Rite of Spring files are 6.7 (Part One) and 6.6 (Part Two).

When I was inputting these scores in 2020, by the end every edit and save was really slow. Just now I tried tweaking some slurs; tweaking was pretty much instantaneous, and saving took 6 or 7 seconds.

Have you tried closing and re-opening the project?

1 Like

Did you uncheck “generate preview” in the info screen? If so, make sure it is unchecked, it becomes problematic with very large scores.

1 Like

Wow, the “generate preview” changed a lot! Thank you.
And the file size reduced to “only” 15.3 MB.

Yes, I have closed and re-opened the project many times. This saving time issue is with this file since quite a while. I was wondering if there could be some error in the file code which can be erased somehow…

I will try the “create a new Full Score layout” tipp as well and tell you how it went.