Very strange input lag/latency problem - help needed

Hi all, I’ve been browsing this forum a lot and I’ve done tons of googling, but to no avail. I’m having the strangest problem with a lag of my input.

I’m using Cubase AI 7 with a UR44, under Windows 7 (i7 + 8GB RAM). I always have my buffer size at 64 samples, providing a total of 8 ms latency. This worked great. Yesterday I was mixing a song, using lots of inserts when I noticed a sudden overload of my average performance load, getting pops and clicks during playback. So I switched to a much bigger buffer size (2048 I believe) to see if that worked. Well, it turned out there was a certain insert plugin that was the cause. After removing this insert I had no problems whatsoever. So I put back the buffer size to 64 samples and got on with mixing. Everything worked fine.

Then today, I wanna add an extra guitar track. But for some reason there is a big lag or latency between when I play and when I hear it in Cubase. And it’s only in this specific project! I did a bunchstuff that didn’t fix it:

  • Double checked I had selected the right driver. I have, it’s showing the 8 ms latency.
  • Opened another project. I did not have the lag at all.
  • Disabled ALL inserts/sends/etc. Still had the lag.

Strangely enough when I look at the mixer, I see in my Stereo In channel there is no lag present!! It’s only in the Stereo Out channel that it’s having the lag. Also, when I check “Direct Monitoring” the lag is gone. So there must be some setting in the project that I accidentally turned on or off.

Or could it be possible that for some reason this project still sees the buffer size as being a lot larger? Even though I’ve changed it back to the lowest possible size?

Please, if someone has any advice… I’m begging here. 24 hours ago I was recording a ton of tracks in this same project with no noticeable lag at all! :cry: :cry:

Does using Constrain Delay Compensation solve your issue ?
This behaviour is typical when using EFX’ses like f.e. the multiband compressor.

look in manual on p. 265 and 228
Cubase features full delay compensation throughout the entire audio path. This means that any delay inherent in the VST plug-ins you use will automatically be compensated for during playback, so that all channels are kept in perfect sync (see “About plug-in delay compensation” on page 228).
However, when you play a VST instrument in realtime or record live audio (with monitoring through Cubase activated), this delay compensation may sometimes result in added latency. To avoid this, you can activate the Constrain Delay Compensation button on the Project window toolbar. This function tries to minimize the latency effects of the delay compensation, while maintaining the sound of the mix as far as possible.

kind regards,
R.

Would freezing some of the other tracks in the project help as well to remove processing load on playback?

Hi guys, thanks for the fast replies.

The Constrain Delay Compensation does indeed work. Also, I’ve tried freezing a lot of the other tracks and that also worked, removing the lag.

I guess my PC is just not as powerful as I hoped it would be. At least, now I know how to work around it. Thanks!

:slight_smile: That button is needed even on the most powerfull systems.
Some things just take too much processing time to calculate in real time. :wink:
Every FX, Synth or other component has some latency and when multiple task must be handled in one of them before the audio can be delivered, that works as a multiplier for the latency.
And this is for every DAW. Cubase gives you the ability to compensate. Not every DAW does.

kind regards,
R.