Very weird MIDI issue

Ok, I’ve got a weird one.

From tonight, CP8 is not playing my MIDI back out when I play in via my controller keyboard. I can see MIDI going in but nothing is coming out.

I have tried different, and new tracks. Two separate projects and a new one. I have tried a different controller keyboard. MIDI is going in but it won’t play either an external MIDI synth, an External Instrument plugin, nor a VSTi.

WTF is going on?

I have tested it in my other DAW and it works as I expect. It is not my controller keyboard or MIDI connections; it is Cubase.




I should clarify: I can see MIDI input via the meter on the transport panel. It will not create MIDI notes

Don’t know if this is helpful, but: I’ve had the same situation with a VST instrument which had outputs that had not been “defined”.

This happened to me on Cubase 7.5. I tried everything I could think of to debug the problem but I was never able to find a reason for it. It’s as if Cubase just (permanently) stopped acknowledging MIDI in. My interface was showing inbound signal but no notes would be recorded and VSTi’s wouldn’t respond.
As it happened I had just installed Cubase 8 on the same machine. I started it up and MIDI worked as expected. Same controller, same MIDI interface, same VSTi’s, same computer. I’ve come to the conclusion that the only way I’d get MIDI back on 7.5 would be to re-install, but 8 Pro is working fine so I stopped worrying about it. I’m not happy to hear that you’re getting the same problem on Cubase 8 though.

Do you see midi activity on the track itself?
Is the monitor icon activated?
Is the midi channel correct?
Does everything look alright in the MIDI Filter settings in your preferences?

Does it play MIDI data that is already recorded?
If so, have you (accidentally?) disabled MIDI Thru, in the Preferences>MIDI dialog?

I can confirm the MIDI problem since Cubase 8.0.5

When in Listen editor, Cubase does not really play every note back out that I played on the keyboard.
Some random notes are created, but most of the notes not.
I can see MIDI going in but nothing is coming out.
When I close the editor everything works as expected.

I have tested it with several latency adjustments but it does not work.

When I open Cubase 7.5 in the same environment with the same project or
VSTinstruments, everything is O.K.

Yes - see above. I’ve not touched any settings but the filter is fine






I have only just started seeing this last night. It was fine (in 8 and 8.0.5) until last night. It doesn’t play any notes back out.

This is a critical issue. I can’t believe this has been in evidence since 7.5 and not yet fixed! it is kind of fundamental, no?!

I’m opening a ticket with Steinberg…I can’t use it at all at the moment. Grrrr



Nor am I!



Thanks for the heads-up but it seems it is everything MIDI-related. It won’t control anything through MIDI


Can you post screen shots of MIDI your input selection in the Standard Inspector Tab (the top one), and also your MIDI port setup from Device Setup?

Is the track Record Enabled, or is Monitor enabled on the track.


You cracked it! Track arm was not selected. That was enabled the night before last!

It used to automatically enable the track record, and now, when I look for that setting, it has changed to DON’T automatically enable track record. I didn’t change it!

OMG thank you. Stupid me for not actually seeing the record arm light. Duh. Panic-stricken tunnel-vison.

Good man.