Video import not working Cubase Artist 12

I have been scratching my head for a few days and I just dont seem to make my cubase import video files properly.

File>import>video file.

I have these 2 videos in mp4 format, one gets " invalid or not supported format" and can click “extract audio from video” but even that does not do anything with either videos.
The other same video ( just edited in filmora) has the same format mp4 and I can get it imported, but has " missing thumbnail cache" which cannot be even generated manually from the Pool… I can get the Audio (of the filmora edited video) imported using the path : File> import > audio from video file.
However, the filmora video has only a black screen in the video player and only shows time.
Please advise.
Thank you

Check this out to learn what Cubase supports:

Also, note the the file extension indicates the container, not the video format. You might have to convert the file. has a good cheap converter that’s easy to use.

1 Like

hi steve.
thank you.
I converted the same video and tried a few formats and made sure that the video frame rate is accepted by cubase. (not variable or non standard frame rate eg: 14.53 or so) so I chose either 24 or 25 or 30 fps for my converted files and then went to project>project setup>get frame rate from video.
however, I am encountering a strange phenomena, I can import and play mov / quick time video but the extracted audio has empty tracks. No audio can play.
when importing mpeg4 / mp4 , the audio from the video is there but the video track is greyed out with missing thumbnail cache and clicking on generate thumbnail cache in pool nothing happens. The video does not play in the video player. The audio plays.
Cubase tells me that avi video is an unsupported file but it should work according to the cubase manual.

please advise.

Hi, The same here, I am trying to import audio from a video and Cubase12 doesnt do something. I try with other DAW and it can extract the audio without problem. Maybe there is a Bug to be fixed.

1 Like

Also having this prob right now… trying to import MP4 (plays fine in QuickTime) but when I select import video → select the file, then hit open nothing happens and the video does not import. Tried converting the mp4 to H.264 but makes no diff, Cubase just won’t import.

Also tried “import audio from video” which also did not work with either mp4 or h.264 formats.

1 Like

MP4 is not a Codec, it is a Container Format . H. 264 is a Codec. It’s is no more possible to convert the mp4 to H.264 than it would be to convert an orange juice can to orange juice.

Refer to the pages I linked above to learn more.

You will have to convert the video…

I use xmedia recode or DaVinci Resolve, as well as the AudioSpot util in the links above.

1 Like

Ok, I got the syntax wrong then… regardless, the video won’t import. It’s an MP4 container with H.264, AAC Codec… which should be compatible
M1 MacBook Pro, Cubase Pro 12 (Rosetta)

There is a frame rate limitation as well. If I remember correctly, it must not be variable frame rate.

There is a frame rate limitation as well. If I remember correctly, it must not be variable frame rate.

Here are the tech details:

Anyone managed to solve that?
I’m on Cubase 12 Pro, macOS Monterey 12.6.1, tried several video conversion options using HandBrake, played with framerates and so, but still, Cubase just ignores that I’m importing video and does nothing after the import.

The same problem with Cubase 13. Cubase 12 imports video, but Cubase 13 do not import the same videos, file “invalid or not supported”.
MP4 files from the phone camera.

1 Like