VIDEO OF Cubase 7.5.2 on OSX 10.9.2 versus Windows 7

Thanks. Actually I managed to read this article. However the link to Hyperthreading contained within the article was the problem. I have read it now. Interesting! Do I have the balls to try it? I don’t know!

Not sure it takes “balls” to try. Pretty simple in Windows. Disable it and see if the performance improves. If so, leave it that way. If not, change it back. It’s about as adventurous as changing your desktop picture. :wink: