Video out of sync with it's own audio

I’ve been having an issue with importing a video of a music performance and the audio is out of sync with its picture.

In QT it perfectly in sync…
Both HD videos and SD videos always 48kHz and 24 bit audio

ALSO, there’s a time lag between the time I hit the space bar and the songs start
and again, when I hit the space bar and the audio stops…

I’ve tried Multi Processor on/off…no difference
I’ve tried ASIO Guard on/off…no difference

I’ve tried adding up to 6 sec of preload…no difference

any ideas, I need to be able to score to film as well as edit audio from live concerts I’ve shot on video
and use the camera mic audio (the one that is currently out of sync) as well as audio recorder tracks
to get the best live sound (audio recorder track might be independent mics or line from live FOH mixing board or both).

would love to solve this, I don’t recall having these issues in C6.5


el profe

Hi El Professor,

and what about the frame rate? Does the project’s frame rate match the video’s frame rate? Open the project Setup and click on “Get from video”.

Hope this helps


thanks for replying so quickly Luis!

the frame rate in QT says: 29.93
(not certain why it’s not 29.97)
I did try to use ‘Get from Video’ but that button wasn’t activated to use.
I’ll try to re-boot right now and see if it works.

When I try that it says “Getting fps from video is not possible”.


HI again, I just opened it up in QT and exported it as a 29.97 fps since I never understood why Apple Final Cut imported it from my camera as 29.93 which is a weird number. And I’ll see if that makes a difference. It was drifting further out of sync as it played and that may also be why that was happening.

hold on, let’s reboot C7 and see…(tic tock)…

Ok, it’s working now and I was also able to use the project windows 'get timecode from video, thought it was set to the right 29.97 anyhow.

So, now my 2nd question was, why is there a time lag between pressing the space bar and the song playing
and also when I go to stop the sequence and hit the space bar, it continues to play for a little extra bit before stopping.

Are there some settings that will tighten that up? Thanks Luis!

el profe :smiley: