Video Playback issues.

Since I’ve updated my MacBook Pro to Catalina my video playback is unusable. On Sierra I had some minor issues but now its unusable. I’m on a old MacBook Pro late 2013 with a NVIDIA GeForce GT 750M 2 GB, 2.6 GHz Quad-Core Intel Core i7, 16 GB 1600 MHz DDR3.

The same videos has no issues with Logic Pro X, perfect and fluent playback. I’m talkning about HD video (1080p), mpeg4 H264 or mov. For this reason I guess the problem is not the computer itself but something related with Nuendo. Someone is experiencing the same issues?

I don’t think this is due to Nuendo video engine. I’m actually testing Nuendo 10 trial on Catalina MacOS and video playback works nice. IMO is more likely that your problem with video playback are related to computer specs and of course for Catalina OS. Apple has implemented Metal2 in MacOS 10.15 for video playback and this technology is based on AMD architecture. Some old Nvidia GPU´s can support OS10.15 but won’t never be so efficient as AMD. Look at new Mac computers: all are AMD based.
Why does Logic work better with video playback? Because Logic and Nuendo/Cubase are different apps. For the same reason that FCPx is fastest than Premiere on Mac. Nuendo video engine has a different technology respect to QuickTime. Quicktime use all Mac hardware resources and apps that support this technology work with video very well. I.e.: I would bet that you don’t have also problems with video playback in Digital Performer

Hi there,
I’ve some updates. Now I’m on a brand new Mac Pro 2019 with an AMD RADEON 580 X 8G. Same Issue I had with Sierra with my old Mac Book Pro. Different computer, different OS but same Issue. Therfore I’m almost sure the problem is Nundo’s video engline. I upload some screenshots to show what I’m trying to explain in words.
The picture shows a frame captured filming my monitor with an iPhone. I can see clearly a horizontal line cutting the face of the woman. Strange thing is that the line affect only the face. Apparently this issue affects only moving subjects on the video. This drives me crasy. I’ve used Logic X and Pro Tools for deacdes without any video playback issue. Don’t understand me bad, I like Nuendo and I wish keep with Nuendo but I hope to find a solution for this annoing issue.
I’ve tried many options, differewnt video coding, different HD for the project, different computers and different OS, this issue persist.

I have also had some updates since wrote my post :wink: . I was testing Nu trial with Steinberg demo projects and all looked like well. But once I bought the Nu10 update I proceed to load a 4k video file and… surprise!! the window video wasn’t able to play it in the correct resolution. I solved this issue making a copy to 1080 resolution with Compressor. At this resolution the video play with no problems
However, the picture shown in your post looks like an inter-frame artefact (mpeg…). When you write in your post “different codecs” , what codecs exactly did you use? Have you try with Apple Prores codec (ie. prores lite, proves proxy)?
Prores is an intra-frame codec very optimised for macOS hardware, have you tried with this codec? What application do you use for transcoding? I’ll recommend you both Compressor either EditReady

I’ve tried Apple Prores Proxy and LT but I don’t own Compressor, I usually import video files in FCPX and share (export) in Apple Prores. But didn’t help. The issue is not consistent and happens randomly. I’ve also tried different monitor resolutions with SwitchresX. Like you said 4K video are not supported by Nuendo.
When I do minor works the issue doesn’t bother me much, when I make music for films then it makes me nervous. In that case I would prefer a fluid image that does not distract me.

Still looking for a solution. I’ve tried also Apple Prores 422. No better results, same issue with this lines that appears randomly and affect only moving objects in the frame. It seems to be like video is interlaced but isn’t. This horizontal random cuts happens only inside Nuendo with really any video or video format. Outside Nuendo all is fine. Anyone has my same issue?

Here some other frame screenshots, check the shoulders: