video player crashes Cubase 9.5 on my computer

I have this problem: Whenever I open video player {on cubase 9.5) this apear white, and crashes my Cubase. I am forced to restart the aplication with Ctrl+alt+del what’s not very pleasant.I tried to reinstall cubase 9.5.0 but we have not solved anything…I reinstaled 9.5.10 but unfortunately same result. Cubase crashes. I nead some advice how to solve this. I read the articles after the internet from Steinberg about video issue, but I heaven, t 77found any result in relation to my problem.I have Cubase 9.5.10, Wave Lab 8.5, HALion 6, Intel I7, Gygabyte GA-EX-58-UD4, Tascam US 16x08 Sound, NVIDIA QUADRO NX 580 video card 12 GB ram memory, 7200 RPM Hard drive, Win 10 64BIT Pro version.
Thank you.

Hi! Did you happen to find any solution for this? I’m also experience this in my Cubase Pro 9. And it’s really annoying and frustrating when this happens and you have projects on a deadline. Can you please keep me posted once you find any solution to this? Thank you! Btw I run on Windows 10 Pro

Hi, in the last days I’ve had the same problem. I’ve never had any trouble before using Cubase.
The only changes I did was (probably) an video card update and installing the Cubase Pro 10 Demo.
No way to solve, uninstalling Cubase Pro 10, uninstalling and re-installing Cubase 9.5, updating and rolling back video card drivers.
Waiting to heard from Steimberg customer service.
Any news from someone? Is there the same problem in Pro 10?
Thanks in advance.

Having the same issue w/Cubase Pro 10, Win 10 Pro, i7 8700K, 64GB RAM, 2 x GeForce 1080ti.

Video player window comes up blank white and crashes the entire application, with or without any actual video file in the project. I’ve tried about 5 different graphics drivers, reinstalling Cubase, deactivating SLI, tweaking various Nvidia control panel settings, adjusting various desktop display settings (I’m running two monitors) - nothing works.

My only option is to revert to Cubase 9, which still seems to work fine.

I’ve lost pretty much a whole day of work to this issue, and it’s extremely disheartening.

Update: I’ve been able to isolate this issue to my multi-monitor setup. With both Cubase 9 and 10, the video window works fine as long as it is on the primary display. When I drag it to my secondary display (which has a different native resolution than the primary) it works fine until I close the video window and attempt to reopen. Then Cubase hangs. If I try to load a project that’s been saved with the video window open in the secondary display, the project immediately hangs.

The short term fix for this is to physically disconnect the signal cable for the secondary display and then load the project. Cubase will drop the video window back in the primary display, and everything is fine. You can then reconnect the secondary display - just don’t drag the video window over there and forget about it. I hope this helps some of y’all.

I have a ticket on this with Steinberg support, and they have been very responsive so far. I am hopeful that a long term fix is on the way.

Update: plugins with graphics acceleration cause the same crash when dragged to the secondary display. This occurs in the latest versions of both Cubase Pro and Wavelab Pro. So far I’ve only had this experience with Fabfilter plugins but I suspect that it would also occur with Waves plugins that use hardware graphics acceleration, etc. Same issue that’s described here:

So maybe this is primarily an Nvidia issue? I’ve had no word from Steinberg support for over a month - assuming that there’s been no progress there.

Issue still occurs with the latest Nvidia drivers in Cubase 10.5 Pro. So demoralizing.

I had this problem for about a year now.
The workaround was to unplug my 2nd monitor when loading a project with video.

After going back and forth with Steinberg support, checking every component of my system, we identified the problem. In my case it was the nahimic service exe that caused the problem. So if you got a asus rog strix motherboard, go check for that.

All working perfectly now here!

I’m trying to look for that Nahimic service exe in my pc but I couldn’t find it… does it differ if you have a different motherboard brand? Mine is Maximus Hero Alpha VIII