Video (re-)attach does not work correctly

Using MacOS Ventura here. I think I’ve found a bug related to attaching videos to a flow. I successfully attach a video to a flow. Then I realize there is something wrong with my video, so I go back and edit the video. Importantly, I place the new video in the same location as the old one. I then detach the video from the flow, and then re-attach the new video. Dorico continues to play the old version! Only if I rename the video file does the new video get attached. It’s as if Dorico is caching the video files by name and ignoring new attachments if the file name already exists. This smells like a bug.


Dear John,
Daniel Spreadbury answered this like two days ago. He’s Dorico’s team head manager, he surely knows whether it’s a bug or a (strange) design decision… In any case, I’m afraid this thread does not offer anything new and a little search before posting could have showed it :wink:

1 Like

Thank you @MarcLarcher for pointing me to the other recent thread on this topic. To me, the behavior is strange and far from intuitive. Though I understand how one person’s bug is another person’s feature. I like the sound of the suggestion from @SampoKasurinen to use txl timecode plugin, though I’ve not heard of that before. I will have to investigate. Maybe it will also save me the hassle of having to convert my Logic audio to video prior to attaching.

1 Like

Setting up the TXL timecode plugin can be a bit challenging at first, but here is how I have managed it:

  1. open logic
  2. open dorico
  3. make sure dorico plays back on your speakers or headphones
  4. set the timecode plugin in one of the vst slots
  5. from the TXL -plugin, select an internal channel for MIDI MTC

I have used an already existing one, here are screenshots of that. Make sure that device is online is clicked.

  1. In logic, set sync mode to MTC in project settings

Logic will recognise automatically the timecode when playback is started in dorico.

  1. Set it up so that bar position 1 1 1 1 plays back at SMPTE 00:00:00:00.00.