Violin 2

I’ve recently made the move to Dorico and I’m in the process of importing all of my scores from Sibelius (saving them as MusicXML from Sibelius, then opening them in Dorico). I am using Note Performer for playback. What I can’t understand is that with all of my orchestral scores, Violin 1 plays as a violin section (as it should), but Violin 2 plays as a solo violin and I can’t seem to change it. The only workaround I have found is to go into Note Performer and make “solo violin” play as “violin section”. Any ideas?

Check in Setup whether Violin 2 shows up as an ensemble or a solo player.

Violin 2 is showing as a solo player, whilst Violin 1, Viola, Cello and bass are all showing as ensemble players

Well that explains your problem.

Workaround. Create a new ensemble player for Violin 2. Copy all the solo violin2 part and paste into the new player. Delete the solo violin 2.
(I’m sure there are cleverer solutions, but this will work!)

1 Like

OK I will give it a try … thank you!

The easiest way to change whether an instrument is held by a solo or section player is to:

  1. Add a new player of the type you want
  2. Press Esc when the instrument picker comes up, don’t give them an instrument - leaving an “Empty-handed player”
  3. Drag your original instrument from its current player to the new, empty-handed one
  4. Delete the original player

No manual copying/pasting required - the instrument and all its music remains intact, it’s now simply held by someone else.


Thanks Lillie, I knew there was a better way!

Just given it a try … works a charm! Thanks Lillie!
Just curious as to why Dorico imports in this manner (of course it could be Sibelius exporting in that manner!)

I think that in general one can’t expect MusicXML to export-import from one notation program to another seamlessly, without need for some editing after the fact. Each stores data in a slightly different way, with different assumptions, and while they generally match up well, there’ll be these little discrepancies to watch out for.

I’ve found exactly the same happens with xml import of violin 2 from Sibelius and it remains a mystery why this in particular. Although I’m aware of Lillie’s solution, it’s well worth repeating as I sometimes completely forget and do as Janus which is fine but takes more time.

A theory: In Sibelius is it one Violin instrument with an extra staff? This gives you the sub-bracket automatically in Sib. If this is the case, the pre-export fix is probably worse than the post-import fix.

Another option is to edit the XML before input, to ensure that players are brought in as Section Players. See this tip: