Virtual keyboard filtered my key commands, although the virtual keyboard isn’t active [solved]

in Windows 10 I also get the annoying messages, that the virtual keyboard filtered my keycommands, although the virtual keyboard isn’t active - neither in the arrange-window nor in the mediabay in the right zone. As I never use the virtual keyboard, I even disabled the keycommand for (maybe accidentially) opening it, but it seems always be active as soon as I open the mediabay in the right zone. (Cubase Pro 11.0.20/Win 10 20H2).

Hi,

The virtual keyboard is called automatically, if you load any VSTi preset in MediaBay. If you close MediaBay in this state (or switch focus), the virtual keyboard remains enabled (but not visible anymore).

To fix it, open MediaBay and select other media type preset to close the virtual keyboard.

1 Like

Hi Martin, thanks for your reply. I just started Cubase 10.5, it behaves completely different.

10.5.20:
Opening mediabay in the right zone,
go to VST-Instruments
open Halion Sonic
open a soundpack
select a preset
→ the virtual keyboard appears in the lower corner of the right zone and is deactivated by default

11.0.30:
Opening mediabay in the right zone,
go to VST-Instruments
open “Halion Sonic”
open a soundpack
select a preset
→ the virtual keyboard does not appear in the lower corner of the right zone but is activated in the background and therefore blocks all my keycommands until I close the right zone.
I also do not see a way to change that behavior.

Is it bug or a feature? :slight_smile:

I added two screenshots showing Cubase 10.5.20 vs. 11.0.30. In 11.0.20 the preview area at the bottom of the right zone is missing, but only in the VST-Instruments-Presets-area In the other preset-types (trackpresets…) the preview-area is the same as in Version 10.5.

Hi,

Can you see the Preview part when selecting other file type? For example Audio loop?

In MediaBay (window), there is a settings, you can show/hide this part of the window. But I’m not aware of this settings for the MediaBay Rack.

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

How do you know this? Do you mean the floating virtual keyboard window?

1 Like

Yes, with the other file types the preview works as expected.

Okay, I did - and it works fine now!

No, there was no floating window. The virtual keyboard in the right zone (and only for the file type VST-Instrument-Presets) was active, but not visible and not accessible.

But disabling the preferences did the trick. Thank you again! :smiley: