voice 2, rests, stems

Hello,
I found the FAQ about starting/stopping v2 to hide rests and (I hope) to return to one-voice stem direction. However, when I try to invoke start/stop voice in properties (either Write or Engrave) after having selected the note that begins or ends where I want V2, the toggle to turn this on won’t stick. It immediately jumps back to off.

I have worked around this by moving and hiding rests, making them 0% opaque. But I can’t find a place in properties (or anywhere else) to adjust stem directions.

So:

  1. is start/stop v2 not yet working?
  2. is there any other way to hide rests?
  3. is there any way to flip stem direction?

Thanks. I am a Finale lifer (from v1), and so far am extremely impressed with Dorico. Learning it is easy, and most everything looks great without the need for much tweaking. Congrats on a great beginning!
David

  1. this is working - but see below
  2. afaik it’s not
  3. right-click and select stem>force stem…

I accidentally managed to recreate what you describe initially
DORICO-EndsVoice.gif
Then I just deleted the half rest in voice 2 by placing the caret and backspacing over it. The rest was automatically recreated. Then I attempted it again and it worked normally. Maybe it’s a hidden bug, the experts will know…
DORICO-EndsVoice2.gif

Although we generally try to hide the dirty details, there is a difference between rests that Dorico creates on its own to fill in the gaps in voices, and rests that you have either input yourself or set a property on (e.g. changing the rest’s staff position, or setting it to end a voice, etc.). Rests that you have set a property on can’t be hidden by setting ‘Ends voice’ on a previous note or rest. But as Frank has found, you can delete such a rest and then the ‘Ends voice’ property on a previous note will work as expected.

Great. That worked almost everywhere, and the 0% opacity trick worked in the two places it didn’t. Also, the right click (Mac, cntr-click) brought up a wealth of great things on a selected stem!