Voices and spacing


Is there a parameter to change to have the first four notes in the example equally spaced ?
I had to use voice 3 with voice 1 to have the notation in the example.

In short, is there a way to move the first note (actually two - two voices) to the left?

I know that we can’t yet move the notes horizontally, but maybe something about the position when more voices are involved?

Thank you.
Schermata 2016-11-02 alle 23.46.25.png

That’s an interesting case; I believe Dorico might do what you expect if the first two notes where a second apart rather than sharing the same staff position. We can look at extending that special spacing case to handle the unison case as well, if it’s not currently handled.

You might find for now that selecting the 16th note and the diamond and swapping their order (right-click, Stem > Swap Voice Order) gives a more pleasing appearance in the short term.

Hi Daniel,

Your solution doesn’t work in this case because the positions are inverted, and the diamond needs to be on the left (and that’s also the reason why I’m using 1st and 3th voice). Or am I missing something?

Unisons seem to work well but I’m not able to change the notehead to a diamond (available only for half notes - we’ve spoke about it in another thread :wink: ).

Could you maybe tell me which would be the earliest solution to come, spacing algorithm or changing notehead?
If it were possible, I can to set up the score to be ready to adopt it.

Schermata 2016-11-03 alle 12.03.48.png
Schermata 2016-11-03 alle 12.01.01.png

did you move some music after your passage?
I rewrite your example with no time signature, and I have this:
so I think it’s possible

Hi dup,

thanks for your time.

The source is from an xml file. I’ve simply added a new voice to get the notation required.

Mmmmh, I suppose I have to investigate… :confused:

Thank you again

The issue seems related to ‘system/frame break’.

Looking at the example I’ve done, proportions are kept until I break the default spacing with a system/frame break.
testVoiceSpace.dorico.zip (587 KB)

I have made some tests, receiving the same behavior.

Could this spacing change be considered a bug, when applying a system/frame change?

Sorry to take a couple of days to come back to you. I don’t think it’s really a bug, no. When you force Dorico to put more or less than it thinks should go onto a system, then you are inevitably going to introduce some spacing distortions of some kind. In the case of this specific spacing situation, Dorico is adding on the width of the voice to the left of the beamed note to the space taken up by that column (i.e. that rhythmic position). It then adds on the ideal width of the note value in the right-hand column, which is the amount of space that is then added in turn for each of the remaining columns in the group.

When the spacing gets looser on the first system because you have inserted a system break to push one bar onto the next system, the additional space is distributed proportionally to each column across the width of the system, but in fact our eye tells us that more space should be added to the first column, where the beamed note is offset. The problem is that in that case, we’ve already achieved the ideal amount of space that the spacing-significant note value should receive, so it doesn’t know that it needs to add on more.

It’s obviously the case that Dorico’s default spacing in this case should be improved, but right now it’s not obvious to me exactly how that improvement should work! We will think about it.

Hi Daniel,

thanks for the explanation.

Sorry to bother you again with this issue, but which path would you consider to follow to obtain the required notation?

Will moving horizontally the notes be an option in the future?

Yes, moving the notes horizontally will certainly be possible in the relatively near future; not in the 1.0.10 update, but hopefully in the next update after that, which we plan to be available before the end of the year.