Volume Automation Curves Cause Glitching when using Larger ASIO Buffers

[Windows 10 Pro x64 (10.0.19041)]
[Cubase 12.0.52]
[MOTU 24io audio interface - ASIO 2048 buffer size]

Hi there,

When applying ‘fast’ volume automation to either incease or decrease volume of a part to zero, say, (-inf dB to 0 dB, or 0 dB to -inf dB), and the automation line between the two points is linear, the transition sounds smooth. It sounds AND exports the same way.

However, upon applying any form of ‘curve’ to the fast volume increase or decrease, there is a noticeable glitch where the volume jumps up and down before the automated transitions end.

EDIT: I’ve tracked down the issue and it appears to occur when using 1024 sample ASIO buffer or higher (at 48kHz sampling rate).

Steps to repeat:

  1. Create an empty project at 48kHz and set the ASIO buffer to 2048.
  2. Create an audio track and put some whitenoise audio onto the track.
  3. Apply varying lengths of volume automation up and down. Try from -inf dB to 0dB and vice versa.
  4. Try different timing - long, medium, short, ultra-short duration between automation points.
  5. Now, apply ‘curves’ to the volume automation.

You will notice that the increase or decrease in volume sounds fairly smooth for longer times between the two automation points where a curve is used, but more and more ‘glitchy’ the shorter the duration between the two points. Cubase also exports the same glitches.

Here is a downloadable project demonstrating the issue:

The demo project also contains two audio tracks with exports I conducted one after another using exactly the same settings as in the project, to check. These can be unmuted using the tool to hear what they sound like. The glitches are consistent no matter how many exports are conducted.

Cheers, Jim.

P.S. Here’s a video demonstrating how I found the bug. This is a project I’m working on. I wanted a quicker fade, so tried using a curve to speed things up and give a smoother transition. The ‘stutter’ sound is what I am demonstrating. Please ignore the occasional “BEEP” sounds. This is something to do with the capture software (AAC 192 audio codec issue).

What are your settings for “volume automation precision” in “audio system page”?

Oh, I didn’t know there was a setting for this. I’ll check after this project finished exporting…

Okay, it says “8 samples”.

I’ve just tried it with random settings between 1 sample and 32 samples, and the behaviour is still the same. I also tried changing the disk preload to a higher value and it’s still the same. I disabled ASIO guard and the same behaviour is exhibited.

I’ve tracked down the issue to the ASIO buffer size. Anything 512 or below (at 48000Hz sampling rate) seems fairly smooth. 1024 and above and it becomes more glitchy.

1 Like

Interesting. Thanks for sharing what you found.

1 Like

OK, I downloaded your test project (replaced the signal with a sine, which is a bit nicer to see…).
And I can confirm, steep curved automation with buffer=2048 is broken, regardless of the precision setting. 1024 seemed absolutely fine here, though.

I guess you could report that as a bug to Steinberg… Personally, I must admit (while it is interesting), I am not that bothered, because I never work with buffers higher than 256…

And compared to C11, the automation precision definitely has improved a lot with the sample accuracy:

1 Like


Tag the thread “issue” or whatever it is please…

1 Like

I tagged it with #issue now. Hopefully someone from Steinberg will see the post.

1 Like

Hi Steve. Apologies for tagging you. Your favourite bug finder here! (Sorry for finding another one!)

This one seems easily reproducible. I have a downloadable project all set up and ready to go.

Cheers, Jim.

continued here: Volume Automation Curves Cause Glitching when using Larger ASIO Buffers(2)