Volume problem with compressors

Hello dear community.

I have a strange problem with Cubase in connection with compressors.
As soon as I apply a compressor (in my example I used the standard Steinberg Cubase compressor) to the stereo sum or a group track (bus track) (as an insert effect), the following effect occurs: At the beginning of the playback, the first beats (in my example, a kick drum) are played too loud. You can also see from the exported audio waveform that there are always these strange volume peaks at the beginning and after the short pause. The volume peaks are sometimes around 2-3 dB, which leads to serious problems.

i also found out that the problem is worse when using a compressor on a group track than when the compressor is simply switched to the stereo sum. but the problem also exists on the stereo sum, although “slightly better” but unfortunately still as before.

I have tested various compressors (all from steinberg and various from Waves and native instruments) and I have noticed that each compressor has its own settling time in relation to my problem. But all compressors lead to my problem in the end.

I have already tested or tried the following points:

PC configuration:

  • 13th Gen Intel(R) Core™ i9-13900K 3.00 GHz
  • RAM 64.0 GB
  • NVIDIA GeForce RTX 3080

-Interface settings:

  • Interface Hardware: Steinberg UR22C (latest driver)
  • USB Mode: SuperSpeed (USB 3.1 Gen1)
  • Sample rate: 48 kHz
  • Mode: Low Latency (Standart and Stable already tested)
  • Buffer Size: 192 samples (all tested between 32 - 2048 samples)
  • Input Latency: 4.500 msec
  • Output Latency: 6.479 msec

Windows settings:

  • Power plan: Best performance
  • No programmes in Autostart
  • Windows 11 Pro (current updates, operating system reinstalled)
  • Hardware performance test / benchmarks performed no abnormalities

Settings Cubase 13Pro
- Cubase Pro 13 (latest version 13.0.30)

  • No automations are available
  • New project created
  • No third-party plugins activated
  • Editing accuracy 64 bit float (32 bit also tested)
  • Multi-processing activated (also tested deactivated)
  • ASIO Guard activated (also tested deactivated)
  • ASIO Guard level (Low, Normal, High) all tested

Export settings for audio mixdown:
-Real time
-Bit depth (all variants tested)
-WAVE file format
-Interleaved

Other settings:

Cubase and the samples used for testing are installed on an SSD hard drive with fast read/write times, so this cannot be the problem.

I was also able to reproduce the problem on another computer

Thank you very much in advance for any feedback or tips on how I can solve the problem.

Please find attached two screenshots which show the problem visually.
(The ramps / peaks at the beginning and after the breaks are my problem…)

Best regards

Robert

Further information on setting the compressors:

I operated the compressor with a moderate gain reduction of approx. 3-4 dB.

Correct gain make-up, no other gimmicks (no sidechain etc.)

What attack time are you using on your compressor? Does changing the attack time affect your issue?

Hi Dunk, thanks for your comment. Yes I have tested different settings (short attack, long attack, different release times, auto release etc.) It has no effect on the problem.

How fast is fast? Have you tried putting a peak limiter in place of your compressor?

And what is the sound that is triggering your compression?

1 Like

Hi Dunk,

To your questions:

How fast is fast:

I have tested attack times between 2 ms to 50 ms with no effect on the behaviour (My problem)

What sound triggers the compression:

Kick drum (I notice it most with kicks, but in principle the problem exists with other tracks as well)

Have you tried using a peak limiter instead of your compressor?

No - it’s important to me to work with compressors. Especially on group tracks and on the stereo sum.

Here is another screenshot of a group track (audio). You can clearly see that the first beat of the kick is visibly higher than the subsequent transients.

Well how fast is your release? I think you could possibly set the release to be slow enough to affect subsequent attacks. In other words if your compressor starts working when the first kick hits and your release is slow enough it hasn’t fully recovered before the next kick which is why it is lower.

In other words if you shorten the release so the compressor has stopped working before the beginning of each kick then they would all have the same fast attack.

Possibly.

Also: How does it sound?

Hello Mattias,

thanks for your effort.
I often use very short release times for kicks, so it can’t be that. In addition, the “settling” of the volume is sometimes several seconds long.

Regarding your question about the sound:

It sounds much louder in the appropriate places, it is clearly noticeable. When I master the stereo sum, the effect is somewhat lost due to the limiter, but you can hear that the drops after the break and the beginning sound somewhat overdriven.


Here you can see an audio track (stereo sum of a track)
The “transient peaks” visibly last several seconds here (the track has a length of 6 minutes to scale)

The settling of which volume?

Ok, but what are we looking at there and what are we talking about?

If you have a kick drum track with a compressor on it and you then feed that to a master that has a bunch of other instruments in it and additional dynamics then of course those other instruments will determine how dynamics work on the new summed signal. So if your dynamics are always working when the entire band plays then peaks might not cut through the way they do after the break since after the break there’s nothing to trigger dynamics at that point.

See what I’m saying?

Here the behavior of the compressor is rather normal. And it’s not a software issue, even hardware compressors have exactly the same behavior, especially when dealing with complex signals. The compressor, in silence, has time to complete the release and therefore the initial signal undergoes a completely different treatment from the one that follows.
Some compressors do that more than other.

1 Like

2ms isn’t very fast for controlling brief transients. If the sample you’re using (I assume it’s a sample) has been processed before reaching you with transient shaping etc, it may well have an extreme transient to it. If you want to take a bit of that transient off, try a peak limiter or a clipping plugin on the channel itself, or on your drum group. You can still work with your compression, you just throw in something else to deal with the brief transients that’s causing you an issue.

Yes, it makes sense to me that the compressor has a different operating point in the first moment than in the following moment when all instruments are fully active.
In my example shown with the yellow waveform, however, the settling time of the volume boost peak is several seconds. Surely this can’t be normal?

Well, we don’t have your project to look at so we wouldn’t know. All I can say is that on my end things are working as expected.

In the meantime I have found out that my “problem” could be solved by changing the sample rate from 48 kHz to 44.1 kHz. Now I only see a very short / compact peak after the drop. Not like in the examples shown with peaks over 3-4 dB which are delayed for several seconds. Thank you in any case for your participation and your suggestions and explanations. Best regards Robert

@robert_franz Would you be able to create some tests that others could follow along using source material other than your mix? Perhaps white noise from the Signal Generator?