Volume suddenly louder when playback stops

In Dorico 2.2, on W8.1, with Focusrite Scarlett 2nd gen.

When I play any section of any score, when playback finishes, or when I press space to stop playback, the final decaying bit of sound is a lot louder than the rest of the played-back sounds.

I.e., it sounds like the overall level of playback is attenuated by about 6dB during playback, and then when stopped it instantaneously goes back up to 0dB even though the samples are still releasing. The effect is startling every time.

Can you give an example? Maybe with an audio export of a demo piece?

The effect doesn’t occur in exported audio, I’d have to record it live. I’ll try.

I made a quick recording on my phone, sorry for quality.

I was sure to press the spacebar loudly before the end to capture it invoking the effect. The final crotchet masks the bug by being silent.

https://1drv.ms/v/s!ArT2_OAi63sCqLcyAHevRslmupUa7w

For the purposes of eliminating the Focusrite driver as a suspect, could you try playing back through the General Lower-latency ASIO Driver and ASIO4ALL to see if the problem persists when you use a different driver?

Does the problem persist if you use a different sample rate?

Does the problem affect all projects?

Thanks for the reply.

I tried the low latency ASIO driver, the full duplex driver and ASIO4ALL.

Low latency generic: same problem.
Full duplex generic: same problem but destabilised the program for some reason. I had to end task a few times.
ASIO4ALL: didn’t work/no sound. Possibly due to not recognising a digital output on my PC. Can try again with extra cabling if you require.

The only real difference was the length of time between pressing space and hearing the effect, which was higher for the higher-latency generic drivers than the low-latency Focusrite driver.

Hope that helps.

I’m not familiar with what kind of control might be provided by the Focusrite software, but I assume you have the most up-to-date drivers and there aren’t any kind of options for applying global compression or limiters or anything on the output from the interface?

Very strange, so it is not the driver. Then I wonder, could it be instrument specific?
What instruments plug-in(s) are you using, always the same? What if you change (presuming you have the choice)?

I’m using only the bundled Halion Sonic library. I can try using different patches, as that’s actually something I haven’t yet thought to try.

The Focusrite driver is here: https://customer.focusrite.com/support/downloads?brand=Focusrite&product_by_type=505&download_type=all

The UI is basically a routing program, with limited mixing facilities and (as far as I can tell) no DSP.

Yes that’s correct. Really just volume control and routing.

Can confirm, same thing happens using any patch in Halion Sonic.

The default audio chain in Dorico has a compressor at the end of it. Even though the compression settings are not very “aggressive”, it has certainly messed up sustained sounds for me, creating the artefact of an attack transient by taking a few milliseconds to “kick in” after some silence. I didn’t hear anything like the surge in level near the end of the audio, though.

Very strange, we never heard of such a thing before and really wonder.
Would you please send me that project file that you showed in the video?
I want to see if it is project dependent and if I can reproduce the issue with it here on my PC.
Please send to ‘u dot stoermer at steinberg dot de’. Thanks.

Will do.

@Rob - Where can one find this default audio chain? I’ve been able to set up compressors in the mixer under Inserts, but didn’t notice anything there to start off with.

This is what I get, for a new project.

The attachment is with the NotePerformer template, but I get the same if I switch the Halion, on the rightmost two mixer strips.

Click Inserts in the mixer to show the data. By default it might be scrolled off the top of the mixer window.

Note, the reason there seems to be a Windows taskbar across the middle of the mixer is because I have two monitors and I dragged the window across both of them to make it tall enough to show everything at once.

Looks like it could be my choral pieces in particular that have this problem, maybe because of some feature I’ve used but can’t figure out.

For instance, I have a couple of orchestral pieces that do not exhibit it. Have emailed file.

@Rob - now you’ve pointed out that compression plugin, I have found it in all my projects.

Hi oggyb,
thanks for the project. Indeed, I experience the same issue here on my computer at home, but I can’t explain yet what is going on there. Also throwing out the compressor from the main out does not solve it. I have to do more tests on Monday when I’m back to the office and also ask others.

Thanks, Ulf.

So, Cubase does not exhibit that problem and it turns out to be, that Dorico - when stopping - sends out a ‘reset all MIDI controllers’ message out to the audio engine, which causes this funny effect. Also funny, no one so far has pointed it out. The effect shows also on other sounds than choir but not so prominent.
Better late than never, thanks for reporting the issue, I’ve entered it into our bug database.