Vouchers for Grace Period updates for Halion, Absolute etc

Hi, I have purchased and activated Absolute 5 on December 4, 2022 but the grace period voucher does not appear in my account.

Absolute 5 is up and running right now on this PC.

Do we have to wait or is there a problem?

Greetings and thanks.

Please read this to see if it answers your question:

This is from Absolute 6 webpage:

" Grace Period:

Customers who have activated Absolute 5 since November 1 2022, are eligible for a free, update to Absolute 6. Go to your MySteinberg account. Go to “Vouchers”. If you don’t see a voucher, please make sure that the eLicenser containing the license is registered in MySteinberg. After registration, it can take up to 24 hours until the free update is available."

Since November 1 2022 , i have activated on December 4 2022.

I suppose you did that? If so, maybe give it a couple days since the vouchers are probably still being added to accounts, since the release was today. That’s how it went the previous time Steinberg sent out vouchers to many users – it took a few days for them to propagate to all the accounts.

Is running right now in this PC (eLicenser OK, Registered in MySteinberg OK ), thanks for your answer, hopefully it’s just a matter of waiting, just a little impatient.

Did you launch the Activation Manager to have a look in there? This will not show up in the Elicenser, which is going the way of the Dodo

Yes, not in Activation Manager

Tried to follow instructions for the H6 grace period upgrade, but not sure I’ve done everything needed. What I have done so far:

The H6 Activation Code was entered in eLCC in Feb 2023. It is showing up in the Soft-eLicenser inside eLCC.
I had an old H6 demo license from years back that I deleted from eLCC.
In the eLCC I ran the "Register all eLicenses at MySteinberg.
I have waited 12h.
There is no H7 or H6 in MySteinberg account under MyProducts.
There is no H7 in MySteinberg account under Vouchers.
The Steinberg Download Assistant, under My Products do not show H7 or H6.
Out of frustration I entered the code in the Steinberg Download Assistant in the Enter your Download Access Code, but it was rejected.

I felt I went through hell to get my C11 Pro to C12 upgrade fully functional, so here we go again. What am I doing wrong?

Hi @RikkShow I moved your post here.

As far as I understand it you don’t have to register the Software Licenses but the eLicenser (in my case Soft eLicenser). I manually copied the Soft eLicenser Number and added it under Register eLicenser in mySteinberg.
Then I was able to see my Abosulte 5 license.
Now I believe I will receive the Voucher soon.

Exactly – so if anyone reading this hasn’t done it yet, do so.

1 Like

I know what my problem was:
I made a reactivation during the grace period which broke the eligibility status.
Steinberg stuff help me and now Absolute 6 activation works ok in my PC.


Nothing yet, no H7 in my web account. Been 24h +…
So I did the eLCC “Register all eLicenses” at MySteinberg again. The new H6 license is on my eLCC as of a few days ago.
I was told to log-in, did so.
Then it gets stuck on the Register eLicenser page when I hit “Continue”.
A message is flashing for a fraction of a second. Could not read it, was so fast.
But after getting a screen capture I see it reads:
“This eLicenser is depriciated”.
What is wrong and can I fix it.
I’m so excited for H7, but this is not fun…

Sorry @RikkShow, can you please post exactly what you’re seeing?

Post the screen capture.

If this is a soft elicense and not a USB key see: https://helpcenter.steinberg.de/hc/en-us/articles/115001627784-Deactivated-deprecated-disabled-Soft-eLicenser-virtual-license-container-

Sure! I just removed the numbers in case it is a bad idea to publicly show those.

Probably it will just take a bit of time for the vouchers to be propagated, as I said above.

As far as the deprecated elc, Read https://helpcenter.steinberg.de/hc/en-us/articles/115001627784-Deactivated-deprecated-disabled-Soft-eLicenser-virtual-license-container-

Hold on. After I screen printed the above picture and removed the license numbers on thaty picture, I noticed the Soft-eLicenser number in the eLCC app is NOT the same as the Soft-eLicenser number in my MySteinberg account. How could that have happened. Both show the Cubase LE number though.

Not sure why that is, but can that be a clue!? What now?

Probably irrelevant, but my C12 Pro license in not showing on any of these places, except on the USB e-Licenser where it says: “Cubase Pro 11 (Upgraded to Cubase 12 with Steinberg Licensing)”
And C12 works just fine.

Sorry bud, It doesn’t look like you’re reading my messages… carry on, and good luck!

I am reading. But my previous post was made before yours was showing in the feed, but now it shows above mine. Stay calm Steve and don’t get arrogant as we try to fix the Steinberg licensing mess. I am not the only one who thinks it is ridiculous and most of the other plugin companies manage to have one app to swiftly manage downloads and licenses. My ONLY goal is to get it work, OK?

I looked at the Depreciated eLCC help instructions you linked to.

  1. There is no red font/text in the eLCC indicating it has been deactivated.
  2. The eLCC is not running in compatibility mode.
    So the two things this help instruction pointed out seems not to be any issue. Screen print attached. I’ll wait until tomorrow as we then have passed the 48h mark and follow up in this thread.