VST Connect Performer defaults to system audio input setting

Even though I have my UAD Apollo selected as Audio Device in VST Connect Performer it defaults to the MacOS setting for input and then it’s the ONLY available input in VSP. :thinking:

Why even have an Audio Device setting in VCP if the system setting overrides VCP?
It’s randomly started up using my iMacs webcam microphone every now and then and it wasn´t until I changed the system input to Apollo that it’s been stable.

A bug?


VCP ignores your Apollo device? Or only the inputs? Outputs are fine?
You wrote : “randomly started up using my iMacs webcam”. Hm. VCP just ask the OS for the default input device. You are sure that your webcam mic is not the default one in your “Audio MIDI Setup”?

Thank you,

Works as expected on my Apollo x8p on my Mac

The problem is that it’s totally random.

My Apollo is set as the default device in Audio Midi Setup and it is chosen as audio device in VCP (which I believe should override any other setting) and yet sometimes VCP choses the webcam input anyway (while STILL showing the Apollo as Audio Device). Very strange.

When that happens I have no other choice than restarting VCP x number of times until it is possible to select an Apollo input in VCP.

I’ve just tried opening and closing it several times to see if I can get it to trip a you describe but no dice here.

This must be incredibly annoying, but I doubt this is typical amongst other Apollo users on mac. It might be a case of fully uninstalling both the UAD and VCP software, using a proper app cleaner and reinstalling. Def do a backup prior though, just in case.