VST Connect Pro 5.5.1 delay issue

My situ:
AMD Ryzen 9 3950X 16-Core Processor 3.50 GHz
64.0 GB
Radeon WX3200 pro
W10 pro 64 20H2 build 19042.1348
Prism Atlas (latest driver)
Nuendo 11.4.1
VstConnect pro 5.5.1
My issue:
I have had a string of days trying to rectify delay issues in VST Connect pro 5.5.1 (I previously used connect pro 4). I deleted all my previous VSTConnect .ini files and started a new 24bit 48khz session. Today again I am getting a variable latency 1186-3000ms delay in my performer’s local recording against my session grid. At 120bpm it can be as much as 3 beats behind to as little as 1 beat behind, from take to take, but it’s always behind. The performer can hear my click and back tracks correctly while I hear the delayed performance and my local recording captures the delay which I am able to play back to the (rather confused) performer. Nuendo locally records what I am actually hearing out of sync. Then I import the HD files and everything is suddenly correct. The previously delayed local files (!) and the newly imported HD files are perfectly grid-synced as I originally intended. I must be somehow monitoring outside of VST Connect but my control rm settings conform to the manual in all aspects. That monitoring issue aside I can’t account for why the local tracks are initially out of sync. Incidentally I also am getting the ‘VST Connect setup is wrong Repair?’ dialog when attempting to “check and repair configuration” under the VST Cloud menu. Selecting ‘YES’ doesn’t do anything and my config setup continues to be wrong. Please advise.

Just to add to nestling’s post, I am the 'performer" in his session. Our conversations have absolutely no delay when conversing. Like talking face to face, so it’s not an internet latency issue. Like he said, there is no consistent delay between my takes. Sometimes it’s a 1/2 a beat, sometimes close to 3 beats (all at 120 bpm). His Nuendo is receiving my performance late. The HD files recorded on my computer are in perfect sync when he imports them into his project. Very strange indeed. He also forgot to mention that he had the same issues with VST Connect pro 4.0.45 (after being able to use it flawlessly in the past), so, we tried the new 5.5.1 version (thinking there may have been some obscure update with Windows, or some other thing), but still have the same issues with the 5.5.1 version.

My first and immediate guess is that on the Studio side, some plugin has been inserted somewhere which has an inherent latency (as VST Connect has). Pls, for a test, remove everything VST Connect from the Control Room, create an empty project, apply “Create VST Connect” and make a test connection/recording. Problem gone? Then move your way up from there.

Appreciate your thoughts musicullum. After doing some 5 new sessions as you describe the previous day, we did several more yesterday; delete all VST Conn pro .ini, reboot, open Nuendo, new project, open VST Connect pro, assign performer input and output, arm performer input and record the performer counting along to my click @120bpm. I add / touch nothing. Normally I would set a mono performer channel but i leave everything as is. Incidentally, throughout this whole process the ‘check and repair config’ option always indicates ‘VST Connect setup is wrong, Repair?’ and selecting ‘Yes’ changes nothing. Control room has no VST Conn to remove.

Sorry to ask once more, are you sabsolutely ure no VST Connect Cue (!) channels are still active in Control Room? You should be able to spot Cue channels engaging the ‘Inserts’ tab within the Control Room View. Also I take for granted you tried version 5.5 on both sides simultaniously.
The only other thing I could think of is that components got messed up. I will ask my colleague. In any case this is highly unusual.

Also you may check the MANAGER tab in the settings (cogwheel) section, it shows some info on the state of plugins. One more time I must be 100% sure that you started out with an ‘Empty’ project (not a template or anything else), sorry to be so insistive but otherwise your problem doesn’t make sense.

Thanks musicullum for your help. We did several more empty (as can be) test sessions yesterday night, both on 5.5. Inexplicably everything worked out of the gate as expected for the first time in 5 days. Everything was sync’d and referenced with no anomalies. Same settings, but this time it worked. The check config still tells me my set up is (irreparably) wrong but it works. Cue heavy sigh w/ mild relief.

Great that it works for you again. Out of curiosity, does the Manger tab show any yellow problems?

Nothing in the Manager tab unfortunately.