VST CONNECT PRO monitor don't work


I started from scratch,
New complete load of CUBASE 8.5
New complete load of VST connect pro
New blank project.
Added one audio track with some ref music

Used “create vst connect”, everything got created with no errors, including the monitor in the control room
Connected via LAN using a MAC book pro (el Capitan) with latest VST connect performer loaded.
Used the default values for the connection
Clicking the editor for the monitor channel opens it up and it will say “connected”
The system synched up with no issues.

can hear the track
can hear himself
can hear talkback

can hear the track
can record performer

can ONLY hear (during talkback or record) the performer if the monitor (little speaker icon on the channel) is activated, I know this is NOT the way to do it since the performer and the track(s) will not be in synch


I followed the guide lines is the manual on page 41 under the “MORE” sections

Hi Kell.

Can you hear performer if you turn off talkback?
I had similar problem. Couldn’t hear performer whenever the talkback was on.
In my case it was Talkback dim setting in Control room. I had it set to minus infinity.

This might not be your problem, but it’s worth checking. Talkback is on by default when you start VST Connect.

Hi misohoza,
Talkdim did not do the work, thanks anyway.
I did set up a real monitor channel in the control room and routed it to the speakers/headphones and that did the trick.

I had the "normal stereo output set for my speakers and that did not work, it looks like you have to have the stereo out configured as a bus, but do NOT connect any audio hardware to it.

I guess it is the same philosophy as you see with the VST connect bus, it needs to be there but is not connected.
Not sure if this is the real reason and reading the manual does not quote explain as so.

You should hear the Performer at any time thru the VST Connect Monitor plugin which you find in the control Room (Studio) after the main output. Can you see this? AFAIK it will always send the input of the VST Connect plugin directly to the main output.

Hi musi,

The monitor plugin was active (showed connected), so that wasn’t the issue.
I guess what is happening now is the main output is “feeding” the two monitor mix I have, all seems to work fine now.

Hello kellrmusic, I’m having EXACTLY the same problem you were having, but I’m afraid I don’t understand the solution you came up with (setting up a real monitor channel and routing it to the speakers/headphones). TBH I’m very new to the control room and it’s very confusing to me. Can you explain in further detail what you did after setting up a vst connect? Thanks in advance.