vst connect pro monitor

By button I just meant clicking on the insert where it is located…I’ve tried the repair vst connect multiple times and nothing happens…when I had a session opened today the only way we could talk was if i had the talkback button enabled (so the performer could hear me)or the track monitor enabled so I could hear him its driving me crazy…should I try to set it up manually like a vst connect se with tb/performer bus etc?

Essentially bypassing the control room?

Try an empty project, Create VST Connect. Unless you messed with anything, this always works.
It always comes down to not to try to mess with routings and settings that aren’t understood. People disable the Control Room or insert or remove stuff, just don’t. Have a look at the Control Room if you still have problems. There should be the VST Connect Cue - it appears to be ok as the Performer can hear you when you activate Talkback (sure, that’s what it is meant for). You also appear to be connected as you can hear the Performer when you use track monitor. You should not have to, because the VST Connect Monitor plugin is at the very end of the chain (after the Main Monitor - yes, somewhat bypassing everything). Have a look at the Devices menu / VST Connections: in the Outputs tab, the monitor outputs should be set to “Not connected”, in the Studio tab (Control Room) the Main monitor should be what you listen to. Then open the Control Room mixer and see if the VST Connect Monitor plugin is located after the Main Monitor and that what you hear and see with the meters is actually your main signal. But first and foremost, just try an all empty new project and apply “Create VST Connect”.

So I created an empty project,did create vst connect,and when I checked the vst connections the outputs were set to my ur22 and the studio was not connected.I reset the outputs like you said they should be and hopefully that will work.Unfortunately I can’t open a session with my vocalist for a few days since he is busy working,but I will let you know how it works out.Thank you so much for your help your advice has given me a much better understanding of how the control room is supposed to work!

When I click on “Create VST Connect,” everything gets loaded – except Cue Mix. I make sure to have all the performer inputs correct. I can see the performer, and I can see a signal from his instrument, but I can’t talk to him or record anything. I’m stumped.

In Cubase, When you play back or talk, does the cue meter (VST Connect plugin or Control Room) show activity? It shows what is beeing sent from you to the Performer. Does the Performer hear you? Is the Control Room enabled at all?

Then, to hear the Performer, the VST Monitor plugin must be present in the Control Room after the Monitor. This ensures that you always hear the Performer no matter what. It should be installed by the “Create VST Connect” function.

So from you to Performer: Talkback and Cuemix (VST Connect Cue) via Control Room. Both the VST Connect plugin and the Control Room should show meter activity when you send a signal. Then the performer should hear it.

From performer to you: visual activity in the Performer Monitor Mixer must be audible at any time thru the VST Monitor plugin unless Control Room is switched off or you lowered the Performer Volume (in the VST Connect plugin) to zero or muted it altogether.

We keep repeating that it is very easy to set up VST Connect via the create function, but it is just as easy to mess things up when you don’t understand the Control Room and start to fiddle with things and most of all not set it back to where it was when you tried something that didn’t improve the situation.

It is close to impossible that nothing gets recorded when you can see the Performer signal in Cubase. Of course, the recording track must have VST Connect as its input. You might try and reset the Control Room altogether (remove all cue channels) and apply “Create VST Connect” thereafter (prefereably in an empty project), assign your Talkback Mic and connect. This has always worked for me.

Thanks for your response. I’ve been recording with Cubase (currently Pro 8) for a few years and feel I have a pretty good grasp on the control room. But, yes, some things still may escape me. Anyway, when I load VST Connect Pro, the VST Connect Organistor window that pops up is attached. I also attach the VST Connections inputs and studio windows.

I’m wondering why the VST Connect Organistor shows the “Load Cue Mix…” grayed out.
VST Connect Organistor.JPG


There are four cue mix channels in your Control Room, all of which are not connected. That makes no sense, pls delete all of them and apply “Create VST Connect” (or “Repair VST Connect”) again. I guess the reason why the VST Connect Cue mix is not installed properly is, that there are a maximum of four cue channels and it can’t create another one. That is why Performer cannot hear anything from Studio.
I already suggested to do that, remove everything unneccessary from Control Room and apply “Create” or “Repair VST Connect”.

Also I recognise that you have assigned hardware Inputs to the VST Connect Input channel. Don’t.
Performer->Internet->Input Channel->Vst Connect plugin->monitor/record. So your VST Connect Input Channel source is usually a hardware input; here, it gets replaced by the Performer signal. Almost as if a long cable was connected from the Performer to the Input Channel. Theoretically, it should not harm to assign hardware Inputs as you did, but this is not how it is supposed to be used, so pls remove them (set to “Not connected”).

Finally, you should also not have any hardware outputs assigned to your VST Connections/Outputs tab as that would cause +6 dB on the outputs if they are assigned to a Control Room Monitor as well. This is a general advice, not specific to VST Connect.

Once you have this all sorted out, save the Control Room settings for later use.

Next version will check for the situation you ran into (too many cue channels), at least the greyed out “Load Cue Mix…” hints the problem. Hope you can get it to work now.

First off, thanks for your input. I am determined to get this to work. But I’m a bit confused on this point…

Deleting the cue buses from the studio tab deletes them from the cue send rack on the mix console, which typically you don’t want to do. Do you need to do this only when using VST Connect to free up a cue bus? (Of course, you always leave the cue buses unconnected to avoid the echoing[double bussing?])

Cue buses not connected to anything are not good for anything, unless they at least drive a plugin like VST Connect Cue. And there is only one stereo cue signal to send to the Performer (mixed with the Talkback) so there should be just one cue mix for VST Connect. The Control Room only allows for so many, and that is why it can‘t create another one. Yes, deleting a cue bus removes the according sends from the mixer, but what would you use four unconnected cue sends for? I also don‘t understand what you mean by „double bussing“; nothing but the cue mix and TB is beeing sent to the Performer.

Yes, I probably didn’t use the term “double bussing” correctly. Sorry about that. I just the echoing you hear if you “connect” the stereo out bus or a cue bus.

“Cue buses not connected to anything are not good for anything.” Hmm. Cue buses should be “Not connected” in the control room studio tab. They are activated when needed via the cue rack or control room. At least that’s the way I’ve always done it. Am I wrong?

So I want to make sure I have this straight: when using VST Connect, it is necessary to delete one (or all?) Cue buses from VST Connection Studio tab before creatring VST Connect, so as to make room for the VST Cue mix. Do I have that right? The most I’ve ever used at one time is two cue buses, so I can certainly eliminate two of them.

Again, I appreciate your input. Sounds like this ordeal is frustrating for both of us!

I just tried again, after deleting two of the cue buses before loading VST Connect. The performer can hear me via my microphone. But he can’t hear what’s playing on the performer cue send. I do see a signal from his guitar, but nothing records. I’ve attached a screen shot of what I see under performer tab. I’m assuming it should say “Cut MIx Plug In Loaded,” but it does not.
Cue mix plug in not loaded.JPG

Hold on. I now see the VST Connect Plug In in my VST Connections studio tab.

See, I don’t know what you mean by that. There is no reason for a delay or echo or the like using cue mixes.

“Cue buses not connected to anything are not good for anything.” Hmm. Cue buses should be “Not connected” in the control room studio tab. They are activated when needed via the cue rack or control room. At least that’s the way I’ve always done it. Am I wrong?

You only need to use cue buses as placeholders if you want to prepare a cue mix in another studio (a rare case, I guess). If none of the cue sends in your mixer is set to any level, you may as well remove the cue bus and add it when you need it. There is no need to use them as placeholders, you can add them at any time.

So I want to make sure I have this straight: when using VST Connect, it is necessary to delete one (or all?) Cue buses from VST Connection Studio tab before creatring VST Connect, so as to make room for the VST Cue mix. Do I have that right? The most I’ve ever used at one time is two cue buses, so I can certainly eliminate two of them.

You need exactly one cue channel for VST Connect, which is added automatically when you apply “Create” or “Repair VST Connect” if it’s not there already. But those functions can not do their work when all possible cue channels are already assigned to something else (or nothing as in your case).

Eureka. I got connected to the performer and can record him. But it’s not in sync when played back. The next situation to deal with…

Thanks again for all your input. Very helpful.

Could the sync problem be because I neglected to disable direct monitoring?

Most probably, yes. Give it a try?

hii. In this vst connect is remote recording the solutions lets that musician the internet connection.

iso 9001 certification in Qatar

Success. I was able to record and all is in sync. Direct monitoring was on.

great, good to hear that and have fun with it!