VST Connect Pro/Performer 4.0.45 problems

VST Connect Pro:
After installation, version 4.01 will be displayed instead of 4.0.45!

VST Connect Performer 4.0.45:
“The program can’t start because api-ms-win-core-winrt-l1-1-0.dll is missing from your computer Try reinstalling the program to fix this problem.”

“The program can’t start because api-ms-win-core-winrt-string-l1-1-0.dll is missing from your computer Try reinstalling the program to fix this problem.”

(Windows 7 - 4.0.44 works perfectly!)

I’m not getting that error message ? try reinstalling ?

Hi,

That does not sound right. Please double-check your installation. Use the Windows “Add/Remove Software” function to uninstall “VST Connect Pro” and “VST Connect Performer”. Reboot. Then install the latest version.

We solved that issue years ago. Maybe 4.01 had this problem. Another hint that something is wrong with you VST Connect installation. Please try again.

Please note that Windows 7 is not supported. But your should be able to run VST Connect Performer on that OS.


See you
Michael.

Performer 4.0.45 works fine after installing the .dll files.

VST Connect Pro 4.0.45 still shows version 4.0.1 after reinstallation. (uninstall and reinstall, twice) Also, 4.0.45 Pro (or 4.0.41 ??) does not communicate with Performer 4.0.45.

If I reset 4.0.44, Pro will show the correct value. In this case, the Pro and Performer communicate with each other. (Also via LAN)
(Windows 7)

obviously it’s not installing correctly
how are you inserting the plugin in the input channel ? are you using the “cloud menu” setup option for vst connect ?
are your plugin paths a bit screwy ? or are you using some custom locations ?
What does the plugin manager say about the location of the 4.01 .dll ?
When you install v4.0.44 what does the plugin manager say about the location of that .dll ?

should be straightforward to work out what is going on.

For VST Connect Pro 4.0.44, you will see this folder: C:\Program Files\Common Files\VST3\Steinberg\VST Connect.

After installing 4.0.45, you will not see this folder, but will point to the C:\Program Files\Steinberg\Nuendo\VST3 folder where the old .dll file is located. But even if I delete or replace it with another, Nuendo doesn’t see the VST Connect Pro plugin at all.
If I re-install version 4.0.44, it will work fine again.

Fortunately, VST Connect Performer 4.0.45 and VST Connect Pro 4.0.44 communicate seamlessly with each other, even when using a LAN.

odd - delete the 4.0.1 version or change to .bak and reinstall v4.0.45?
are you sure you are installing the VST connect installation and not the performer one ?

If I delete version 4.01 from the C: \ Program Files \ Steinberg \ Nuendo folder and then install version 4.0.45, Nuendo will not be able to open VST Connect Pro at all. If I put the .dll file back, you will see the old one.
4.0.44 does not have this error. Then the C: \ Program Files \ Common Files \ VST3 \ Steinberg \ VST Connect folder is seen by the plug in manager. For 4.0.45 you don’t see this.
Performer 4.0.45 works flawlessly.

I tried to install both versions several times, always the same thing happened.

if you PM me I can send the latest .dll file so you could just replace the 4.0.44 dll (might not get chance to send tonight though)

you could also probably just pull the .dll file from the installer too if you know how ?

Thanks!
I thought the two windows-dlls (api-ms-win-core-winrt-l1-1-0.dll and api-ms-win-core-winrt-string-l1-1-0.dll) should also be copied to the Common Files VST3 folder.
As in the VST Connect Performer folder before. I’ll try this again.

One more note: VST Connect Performer does not like the Audient ID44 interface. It starts thinking for about 40 seconds at startup, sometimes giving an error message. Starts fast with Focusrite Scarlett, works well.

I think that’s unlikely ?

You’re right. I tried, but it didn’t get any better.

let me know if you need the .dll

Thanks! But I don’t understand what kind of .dll it is?
Why isn’t it included in the 4.0.45 installer?

the dll IS included with the installer - but something isn’t installing correctly on your system

hi soundhunter

thanks for the PM
I’ve sent you 2 files, a .vst3 and a .dll

VST connect.vst3 goes in:
C:\Program Files\Common Files\VST3\Steinberg\VST Connect

vstconnect.dll goes in:
C:\Program Files\Common Files\Steinberg\Shared Components

Think that should be enough to get it working

It’s odd that these aren’t being installed for you ? - are you SURE you are running the FULL VST connect PRO/SE installer

https://www.steinberg.net/en/support/downloads/downloads_vst_connect_pro.html

and selecting the correct options ? Maybe it doesn’t like your win7 install but I think that’s pretty unlikely to be the problem.

Hello DR,

thank you very much i tried. Unfortunately, that didn’t help either. So far, I’ve installed all the updates since March 2020, all of them worked flawlessly. Unfortunately, 4.0.45 does not.

But no problem, because I had nothing wrong with 4.0.44 either, we were always able to work with it for long hours. It also works well under Nuendo 8, Nuendo 10.2 and Nuendo 10.3.

And VST Connect Performer is the latest 4.0.45 and these two communicate well with each other.

what happened when you installed manually ? I know you are happy to sick on .44…but it would be good to find out what went wrong to help others in the future…maybe even you next time when version 5 comes along :wink: