VST Connect & VST Connect SE - Solution Thread

Has anyone got this to work?

I am trying with someone and all we get is a “no reply” message after he puts in the key I give him after I log in.

Any help would be appreciated.

Judging from your sig line, it is because you are still running Cubase 6.04 :smiley:

Seriously, haven’t tried VST Connect yet. Interested to see if you can get it to work.

Mike

Has anyone tried this and got it to work yet?

Tried doing it here with two computers in my own house (both connected to the internet), but can’t get it to work. Logged in from studio computer after setting it up per the PDF manual instructions. Then, when try logging in with the key id on the “performer” computer, it says that a studio with that id is not logged in.

Also tried doing it with their built-in template on a new project. When I try to connect on the “performer” computer, it just gives me an “unknown error”.

you can not connect within your local network, a connection requires two different ip addresses. Currently, “Unknown error” is beeing reported, the next update will tell you exactly this.

I am trying to connect to other locations with no luck.
-D

if it says “No connection, you may try again later” that means the connection server has accepted the key and everything, but the peer to peer connection fails. In this case, one of you has to open (“forward”) UDP port 51113. See the manual (click the question mark icon).

i have the same “unknown error” problem. if anyone wants to test it with me send me a private message with a the log in key and I’ll connect, or vice versa.

see if you can connect to key: 36803 84717

changed it to 73934 65739

I tried it out with my buddy and it worked!

Hi
I can’t get this to work. I am using the mac version of cubase 7 and VST Connect performer.
My router is configured to accept udp port 51111-51113.
The studio computer is on a raw internet line without router/firewall.
Both firewalls in the Macs are off.

I have made a wireshark trace to see what´s going on.

Both computers connects to the Steinberg server: ip: 194.6.195.159
But when the peer to peer connection is to be established both computers send on port 51111 and 51113 to each other but nothing happens in the apps. The packets data includes the data “hello version 28” which seems to me to be a sort of keep alive message. After a while it times out.

It also seems a little bit odd of which computer that starts the negotiation after the server connection is established. I have tried different connection methods and therefore different IP-adresses. It seems that the computer with the highest address starts the ptp negotiation. This means that the one with lowest IP needs to have its router/firewall configured correct. This is not good since that cannot be the clients task (performer). It shall always be that the performer has to establish the ptp connection. The studio shall be the “server” and the performer shall be the “client”.

Anyway Steinberg: The VST Connect SE is a terrific idea but right now it does not work. And make sure you are using correct client/server behavior so firewalls/routers in the way can be configured correctly. Maybe using uPNP is something to consider as most people using Cubase are musicians and not computer networking guys.

Regards
Anders

Even in a local network computers have different ip addresses …

True, but if you are behind a router the steinberg server will se the same ip address and since the udp ports are fixed there is no way of port forwarding to the right computer.

Regards
Anders

I would love to see this work…I cannot get it to work.

Does anyone have this working reliably at this point? If so did you have to set up your router any way special?

I can log in and get a key, but the 2 machines fail to connect to each other.

You have to port forward udp ports 51111 to 51113 on both sides. But I can not get it to work even after that.
I can see the traffic coming to the computers on each side but nothing happens.

I was able to set this up with a buddy. We could see each other from the webcams (The video is flaky to say the least)and hear each other from the To Performer and Performer monitor but I could not record his audio using the built in template. No audio is passed through the “Performer Rec” channel when sourced to “TB/Performer”. I have followed the guide and the video to the T but with no success.

Then the implementation on steinbergs side is insufficient , as the combination of ip/port should be unique for each machine.
Networking for beginners…

So true, and the server should respond to the client source port not the fixed 51111 or 51113.