VST Connect & VST Connect SE - Solution Thread

VST Connect REQUIRES a web cam. Without a webcam VST Connect will disconnect with a message “Connection Timeout, Disconnected”. We were trying to do this without cameras but it wouldn’t let us. Also, beyond what I did below, I found that the Behringer ASIO driver would not pass audio either way. No sound. We switched to the ASIO4ALL driver at the performer end and it solved that problem.

Here is my original post when it didn’t work

We connect and then disconnect with “Connection Timout, Disconnected” message. We have forwarded all port 51111-51113 (at both ends for troubleshooting), tested the forwarding with PFPortChecker from portforward.com. Tried putting both the computers on the DMZ… same problem. Leave this off, it won’t make a difference if the ports are forwarded properly. Should I enable ping on WAN? I’m about to.

I went to speedtest.net and tested my internet speed and his. Both have 3.5mb upload and 26mb download - and 16ms ping on his and 15ms on mine. Way more than the requirements of 256kb upload and a great ping.

Both running 64bit Windows 7 - Performer has nothing but the client performer software and a Behringer usb audio input which when my track was set to 96khz and 32bit floating, I got a message from VST Connect that I had to change to 48Khz and 16 bit to match the settings on the performer. It made a proper handshake there.

I can see the Performer audio settings - for the 5-10 seconds it stays connected. It is really connected.
He has never been playing while I’ve been connected, not sure if we would hear anything.

I tried to set my remote delay compensation to various levels up to 20 seconds. Still drops within 10 seconds.

I’ve used the preset template and made 2 of my own - I understand how it works. Performer Group track routing is TB Performer in and To Performer Output. The VST Connect and SE plugins come alive during the connection. They are in the Insert locations on the input channel for VST Connect and the performer group channel for VST Connect SE.

This was all solved with port forwarding, ASIO4ALL driver, and Web Cams at both ends. My Focusrite Saffire ASIO Driver on the cubase end works fine and did not need an ASIO4ALL. I’m going to test 96KHZ 24bit or 32bit floating with another friend today who has a better audio device.

You do not need to enable the WAN ping for this to work.

Please POST REPLY any other solutions

VST Connect REQUIRES a web cam.

This isn’t true. My friend and I just ran a (semi) successful session with only a webcam on my (the engineer) side. I’m on an iMac with 10.8.3 and he’s on a Windows 7 PC.

If either audio or video (or both) are streamed, the connection should not time out.
As said before, a timeout occurs if neither audio nor video is streamed (when nothing is beeing received, the receiver assumes a broken connection). This will be fixed with the new version which will keep the connection alive even if no media are streamed.

The problem was with an Apple Mac OS connection. Once a PC user with Windows 7 connected I could record his guitar track and listen to his connected microphone.

Perfect! Because the main problem I’m having with Connect SE is that the connection time out. Within the first half-hour of testing it constantly time outed, then suddenly it started working. At least when not touching any controls and just talk back monitoring back and fourth. Whenever I tried to adjust the performer controls or monitor the performers audio, the connection broke down most of the time. Recording audio went okay, though I got occasional clicks and glitches on the recorded track even with three second remote delay compensation.
The auto scaling latency/buffer size function is not optimal, personally I think it would better to let the user set the buffer size and be able to raise it if glitches occur during talk back. In my case be able to lower it when on a really fast Internet connection.

Connect SE is a really innovative function and I’m going to use it a lot when it works properly.

Keep up the good work

Sound On Sound contributor

I received this form Steinberg support.

VST Connect is not supported for MAC OS 10.6.8. It is supported for 10.7 and 10.8.

Thank you!
a) I haven’t come across a connection breaking down as long as any audio is sent. “Breaking down” in this case I assume means disconnection? That’s odd, then, especially when recording audio is basically working…?
b) what do you mean by “auto scaling latency/buffer size function”? the only existing close to that is the remote latency setting, which is user controllable. Actually, nothing is auto adjusted.
It should not be necessary to raise remote latency to more than 1.5 or max 2 seconds worst case. If the connection is shaky, it almost always means that you (mainly, the Performer) are using WLAN and/or are downloading, viewing youtube videos etc (one gets so used to this…been there myself), or you (or Performer) just have no better upstream from your provider. Check one of the many speetest sites; a minimum of 256 kBit upstream is required, and even that only works if you set all upstream settings to minimum, 384 should be ok for basic operation.
One more thing…could be that disabling ASIO Guard helps, it works ok here though.
Let me know when there is more where we can help.

Yeah, like I wrote, in the first half hour of testing the connection disconnected after ten seconds or so, no matter what we did. Then it started working better, but it was still a shaky ride.

Strange, because sometimes the short latency during talk back got audibly longer, we heard it because we had a hands-free cellphone line as backup talk back. We both heard that the latency sort of scaled up and got longer, then it got shorter after a while. Why not let the users set the buffer size of the talk back connection as well?

We cleaned up all background programs due to the shaky performance of Connect SE and we were both on pretty fast connections. Been using the Digital Musician Container software for online collaboration without any hickups for several months, so our Internet connections are definitely good enough. The DMC software is just hopelessly difficult to maneuver in a creative way, so we have high hopes for Connect SE. :wink:

Well, I’m on a pretty fast ADSL connection - IN: 31,24 Mbit/s OUT: 6,30 Mbit/s PING: 30ms - according to a speedtest site. My co-writing partner is on a 3G connection that’s actually very stable for being mobile Internet (works flawlessly with DMC) and his speed varies a bit - IN: 7-12 Mbit/s OUT: 5-8 Mbit/s.

Internet connection speed or stability really isn’t an issue for us.

Ah, can it be ASIO Guard that varies the latency?

I will try Connect SE with ASIO Guard disabled.

When I have the time I will write down a couple of suggestions for improvement.

I really want this function to work, it will save me a lot of time and effort when co-writing with online collaborators.

Keep up the good work

Looking at your connection specs that doesn’t make much sense. There is a connection timeout of 10 seconds but that is reset with every audio or video packet received. If you contact me privately we could try a test connection.

Oh, I see. That is when no playback is rolling (chat). There, it indeed tries to adaptively reduce latency when possible. Sure we could make that adjustable. Sorry, blind for the easy parts, focused on the difficult connection and recording stuff :slight_smile:

great, looking forward to it! Thanks for your support.

The same issue here: Sorry, connection failed: no reply. You may try again later.
I used vst project SE. I have 2 computers with 2 diferent internet conection (2 separate company provider) one of them cable one of them wirles rooter. I can’t conect this 2 computers between.
OK i have a question. This new technology can connect only two computers ( the engineer and performer} or can connect more computer let say for a whole music band - four or mybee more musicians?

I have a similar setup here. You most probably have to open UDP port 51113 to get a connection going in most cases (though it works without in my case). Thanks to Anders’ help elsewhere in this thread we found a problem which prevents connecting to work as intented under certain circumstances. This will be fixed with the next version.

No, this is a one-to-one thing. Other use cases with more than one party are certainly possible, though.

When I apply the plugin “VST CONNECT SE” on the input bus, a message of “error caused by the plugin, save the project and restart cubase” appears, and the plugin window goes black and there is no user interface.

Macbook Pro 9.1, 2,6 Ghz, 8 GB ram, (no retina)
Mountain Lion 10’.8.2
Cubase 7.0.1

In Mac Pro 5.1, Mountain Lion 10.8.2, 24 GB RAM, Cubase 7.0.1 the error don´t appears.

I am sorry but I do not see a solution in this thread. Have been trying and trying to no avail with the same experience as musicullum described on Dec 29th. Both my friend and we have opened ports 51111 - 51113, nothing… Has anyone in the U.S. made this work? So far the answer is NO. Can anyone help??

There are many successful connections (in the U.S. and elsewhere) but also some that fail. Thanks to the help of people in the forum, we will have better connectivity with the next version, but unfortunately it takes time to make it available.
We can try to make a test connection to further investigate your specific situation if you wish so, feel free to drop a PM.

For me, it works like charm… Even tested successfully with the performer running on a 3G mobile internet connection and still the recording quality was amazing !

Still not having a very successful VST Connect session here yet. This time I tried it at the studio (previously I was connecting with my collaboration partner from home). When I was at home on my iMac I had a solid connection that stayed alive but there were ticks and pops. I tried various settings with the audio upstream rates. Would a much higher Remote Latency Compensation value fix this? Does a low “upstream” rate lead to poor quality recordings or does it only affect the quality of the performer’s monitoring? I’m not sure why I was having these dropouts. I speedtested at 1.5 down / .9 up. I realize those are poor but they’re still well within spec. My friend’s connection was over 10 down / 7 up.

As for the studio, I have the ports forwarded as necessary. My internet is fast (22-25 down/7-12 up). I connected with the same friend (same high internet speeds) and this time the connection timed out after about 10 seconds. I would see the audio for his mic on the VST Connect plugin and hear his mic while we were connected. I would also see level for his instrument but not hear anything from it (guitar amp in another room of his). The only thing I can think would have caused the timeout was that neither of us was streaming video (we were handling video on our phones) although musicullum previously said you only need one or the other to maintain the connection.

I just realized the studio computer is running OSX 10.6.8 … I think I read somewhere that 10.7 is the minimum for VST Connect SE …

This technology is too difficult. Not user friendly at all.

Please fix that.

I watched the video and laughed.


What shall be fixed there ? - In the most cases, what I´m reading here, the reasons why it is not working is that people have troubles with their firewalls… That´s not a Steinberg problem. The routing itself is just logic, there´s even the ready made template, which can be used for it, in the list… I don´t see, what Steinberg can do more than this…!? - Nobody said, that it will be easy to use, and this is what most professional software has in common… There´s a manual - read it ! :wink:

while that is true, there will also be improvements with following versions reg. both connectivity and ease of use.
Also, when you have set up a regular recording session (studio, control room) you have almost made it, additional steps for remote recording are pretty few.

Hi Musicullum, are you a developer acting on behalf of Steinberg? Forgive me if this was explained previously in this topic.

Thanks, you seem to be the most knowledgeable on this software.