VST Connect & VST Connect SE - Solution Thread

So we finally had to time to set up the VST connect feature.

First - we couldn’t connect. Problem solved quickly by bypassing routers, switches and connect directly to the internet modem.

Now everything works fine, BUT when recording, the perfomers’ sync meter is about 30-70% while the studio has 100%. Dropouts all the time! Switching studio and performer - same result. Both with premium internet connections.
selecting different upload speeds doesn’t do the trick. What are we doing wrong?

And… there is more.

After testing it is clear that the performers’ sound card latency setting has inpact on the recording. Choosing a high value makes the recordning go out of sync. The studio setup however is not dependent on it’s latency setting.

We don’t know how to proceed?

Any input it appreciated. Thank you.

Dropouts, the 100% meter, and that Performer settings have impact on recording sync indicate that routing on the Cubase end isn’t set up correctly. The VST Connect Cuemix plugin is often inserted in the wrong place (i.e. master channel…) It must be inserted in a group channel, and that group channel must be routed to the master output channel. This is because the cuemix plug is responsible for adjusting Remote Latency Compensation of the VST Connect system.
If you are still having problems feel free to drop me a PM so we can set up for a test.

I did every step of as written in the manual. CueMix on the group channel and so on. But I would be glad so set up a test with you, musicullum!

I’m having a tough time w/ my setup w/ VST Connect. I do have active connectivity to the performer and talkback is working - actually recording is working as well. My problem is that what I’m recording seems to be everything I’m hearing - this includes the instrument tracks that I’m playing, the performer’s VOX, the reverb, etc…,

I’m not sure if this is how its supposed to work? I was assuming this should record the performer dry (even though reverb may be set in the VST Connect window and I’m playing the instrument tracks).

Did anyone else have this problem?


Most probably, you have the “Mon” switch in the Performers’ panel activated. This is only meant for checking what the Performer actually hears, you don’t want to record that. I guess there should be a warning when it is activated while recording, OTOH recording the Performers’ cue mix is a valid option for checking sample accurate sync.
Hope that helps, if not feel free to ask again or write a PM.

Hello all,
I would like to share my experiences so far with vst connect se and hopefully find a solution to my issues with it. I am based in the uk and my cousin/gtr talent, lives in miami. I have used all manner of programs in the past with horrible results so was waiting for this for a long time to come around. My net is 100meg down / 10 meg up, cousin has 20 down and 5 up maybe better. We can connect first time every time with no disconnects. Video is fine talkback is fine, i can control his side etc, change settings and the like. The issue is in the recorded audio quality regardless of bitrate, buffer size, video switched off and all in between. I get drop outs, glitching, silence, even though the buffer indicators for both sides are solid blue. However the material i do receive is sample accurate, so the program is working as expected its just the audio quality is nowhere near usable for me. It also sounds like digital clipping is present even though all signals are well below levels that would induce this. We keep trying vst connect hoping to stumble across something we may have missed but i think i have exhausted all avenues outwith the program. I can apprecciate the distance involved etc but i dont think that affects vst connect as the latency compensations side of things takes care of that. i am not looking to jam with this, i am purely trying to record the talent with acceptable audio quality. i.e no drop outs or glitching or clipping. i would love to hear from others who are having brilliant results and not just ones with problems as both sides are valuable to learn from. I cant however rule out that my computer system may be the cause to this issue. I have no problems with running and using C7 localy with large or small projects, no latency issues no drop outs etc. All seems to be correct on the miami side. has anyone used vst connect over such extreme distances and what was your experiences ? Would love to hear. I hope i am just one of the minority that hasnt quite got it sorted. For me this is the way forward. So thx in advance for any help or pointers as to what could be the cause of my particular problem.

Thanks Musicullum. I’ll have to give this a try!

rokster: all seems to be set up correctly…I sent you a PM so hopefully we can sort it out. Long distance shouldn’t be a problem because of latency compensation, as you already pointed out.

I did a short test session yesterday with a singer living about 500 km away from me.
She used her macbook on wifi with the built-in soundcard and though this is not recommended everything went smoothly - only one small glitch which I’m sure will go away when she gets a better soundcard.
This is the future! :slight_smile:

I don’t know what happened… - but after updating to 7.03 VST connect doesn’t work anymore :frowning:
I didn’t change anything. All is set up as it should be - we can hear each other fine and the performers track show activity when she sings. But the moment I press play or record she is muted and nothing gets on the track. She still hears the music.
Anybody else with this problem ?

im connected with a mac pro user and im on CB7 with win8 we can see each other but I keep getting a wrong sample rate box coming up… we are both set on 48,000 from top to bottom on preferances… but still no audio

Sample rate is fine here.
Do you have sound when transport is not running ?
Everything works fine until I press play or record - then the performer is muted.

The VST Connect SE plugin sends a message to the Performer application, asking it to change its sample rate to the Cubase rate. Usually this works automatically, but some audio interfaces can not be switched to another rate externally. In this (rare) case, the performer has to manually set the audio device to the same rate that the engineer with Cubase has.

Mads, I don’t think this has anything to do with your case. We’ll connect and find out soon :slight_smile:

We sorted it out - thanks for the great cooperation, Mads!
It was because the Remote Latency setting was set to 0.1 seconds, with no appearent reason - that’s way too few, and we’ll make sure that it can’t be set that low in upcoming versions. Remember it takes time for the headphone mix to travel to the Performer, and it takes time from the Performer back to Cubase, both with latency and the internet in between which is often unpredictable. So you should set it to 1.0 seconds or so to be on the safe side.

Mmmm I can’t stop this box that keeps popping up and saying wrong sample rate… The strange thing is I’m getting the message and not the performer :frowning: so frustrating we’ve both tried 44.100 and 48000 but no joy

What is the performers’ audio hardware? And could you possibly let him try some other audio device, or check with another Performer?

Hi Musi

I had my first real online writing session today using VST Connect SE and it was quite productive. The connection worked flawlessly for several hours without a glitch and the sound quality was great.

Here are some thought and suggestions for improvements.

I’d say that a [Rehearse] mode is a very important function that needs to be added. Because right now only the talent can express musical ideas when Cubase plays the project. The producer has no easy way of being creative without first recording the ideas. Adding a rehearse mode which enables the sound from the tracks in input monitoring mode to be sent to the “To Performer” group track and sent to the collaborator, will enable the producer or sound engineer to add ideas in a creative way. Please add this functionality soon! :slight_smile:

Communication is everything, so please add a talkback lock function for the producer so that he or she always can talk with the talent. No matter if Cubase is in playback, record or rehearse mode. Both parties need to wear headphones anyway, so talkback latency won’t be a problem during playback or recording.


Mmmm I can’t stop this box that keeps popping up and saying wrong sample rate… The strange thing is I’m getting the message and not the performer > :frowning: > so frustrating we’ve both tried 44.100 and 48000 but no joy
Dj Aaron B New Member Posts: 24Joined: Wed Jan 11, 2012 7:50 am

well this problem has been solved but I don’t really know why :blush: while I was having this issue I now realise that I had HP audio drivers waiting to be upgraded and waiting for a reboot…? I cant find any other answer for why it kept saying we are on different sample rates when we were ? anyway now the wrong sample rate box has disappeared when we connect there’s still no audio. when I click on the settings wheel the bottom box just says Audio (not connected) we both have our cards and devices set right :frowning:

That is…in the Performer settings in the Cubase plugin? “Not connected” means just that…what do the other items in that view say? Did you try a second time, mean to say does it happen every time? You understood that the “Performer” settings in the Cubase VST Connect SE plugin are remote controlling the items on the Performers’ computer, did you?
If all else fails feel free to write a PM. So far we sorted out each and every problem :slight_smile: