VST Connection Outputs disconnecting upon Open

I found a bug with the vst connections. The “exclusive device ports for monitor channels” preference is broken. Here is how to recreate the issue.

  1. It’s best to start with a clear, brand new preferences file for the sake of testing.

  2. Go to preferences and UNCHECK “Exclusive Device Ports for Monitor Channels” in the “Control Room” section

  3. Now in the “VST connections” activate the control room under the “studio” tab and assign “Monitor 1” to your two main outputs (device ports)

  4. Go to “outputs” tab and assign the stereo out to the same outputs in the device port as control room, you should be allowed to do this because of step 2. This part still works.

  5. now save your project and close it.

  6. Now reopen your project and you will see that your stereo outputs are no longer assigned, however the control room has remained.

Result = disabling “exclusive device ports for monitor channels” in preferences is not working. when a session is reopened any outputs shared with the control room will be “not assigned”.

This was not the behavior in previous versions of cubase. right now the only work around is I have to assign a preset to my outputs and every time I open a session I have to load that preset if I want to continue using the control room.

System Information
Mac 10.10.4
Cubase Pro 8.0.20