Vst count limit - Steinberg please do something!

Haven’t tried a recent version but remember previous versions had big problems with automation. Anyway, all crutches away - this simply should work out-of-the-box!

If someone who owns it kindly do a test.
I feel it won’t solve the problem and take an additional slot or 2

his might solve your issue?

Specfication for this “Patchwork” Plugin from BlueCat: Configurable VST, VST3 or Audio Unit plug-ins rack: host up to 64 third party plug-ins or instruments in series or parallel.

I think Bluecat has same Limit ( 128 Plugin), ( 64 slots reserved for own plugins “built-in effects”.

@GeorgeV

I feel it won’t solve the problem and take an additional slot or 2

But because you can Patchwork load into Patchwork self ! (new version), Bluecat has allready modularized his Plugin now .
Bluecat has modularized its tool into several instances, as I suggested for the tracks of Cubase.


https://www.bluecataudio.com/Blog/tip-of-the-day/patchwork-2-1-whats-new-a-closer-look/

@aaandima

But because you can Patchwork load into Patchwork self ! (new version), Bluecat has allready modularized his Plugin now .
Bluecat has modularized its tool into several instances, as I suggested for the tracks of Cubase.

I genuinely hope for a solution. If someone who owns Patchwork can confirm this?
It’s not about the ability to load a plugin. In Cubase theoretically you can load unlimited plugins.
Its about this Windows limitation. ie the maximum dlls allowed within an app/exe/Cubase
Unless it works outside Cubase like JBridge

Actually Fabio told me last year the programmers were looking into this idea os spawning new processes once the limit is reached. Jbridge is one way around it but its not tidy!

IIRC, I was listing some of the (theoretically) possible approaches. But I later confirmed we were moving to dynamic linking for Cubase.

While I’m at it, expect to be able to load a few more instances with 9.5.10 already. The change won’t be applied immediately application-wide - meaning this first change will be marginal, but will gradually be introduced in different modules in order to be able to monitor the behaviour and get feedback from you. This will raise the limitation once complete, hopefully to the point some users won’t even reach it, but as discussed previously to fully resolve the problem needs action on the VST devs side, too.

I don’t expect MS to do anything to change the limitation - I have discussed at length with engineering over here and what I got from them is that the limitation makes total sense from an architectural point of view (system stability and performance).

Have a nice week-end :slight_smile:

Nice to hear something’s happening! :slight_smile:

it will happen only in 9.5 ?
i mean, i should update now, or i can wait patch for 9.0 :question:

Thanks Fabio I hadn’t heard about the shift in strategy about moving to dynamic linking. Hopefully in time that sorts this out whilst not disimproving application stability! Great news that a way forward has been decided and improvements are starting to happen.

Any ballpark on a 9.5.10 then?

Do you have a list of main 3rd party vst developers who worst affect this limitation so that we all can lodge requests for a fix? I know UAD are one.

All the best

Martin

Great news Steinberg is working on it. Let’s hope 3rd party plugin developers do the same…

So happy to see you paying attention to this. On 8.5 until I know this works better.

Well, that’s weird. I can’t load more than 11 UAD plugins in a project I have. CPU usage not even at 20%. This is in 9.5; I switch over to 8.5 and it seems like I can add plugins until I’m blue in the face. Everything else on my system works great so UAD problem seems a bit random…

Strange things happend in my project :
I have project 70-80% loaded
And i trying to add some plugins to master channel, and they not load(but not all, some plugins)
I know about this problem, and guess if i freeze all my Audio,midi, instruments… i free up some space for others plugins.
I freeze everything! except 3 Send channels (2 Reverb,1 delay)
and i still cant add plugins to master channel!
I mean there no difference if i freeze everyting in project, and if i open fully loaded preject (load goes down from 80% to 20% with freezes)

Sometimes, if i reboot my PC, and open same project again, i can add some new plugins. BUT, if i save project with new plugins, and re-open again, they wont load.

Sorry for my english, i hope u understand me

@djgraver
Since freezing tracks makes no difference try rendering some tracks (with channel settings) and then delete the original tracks. To be safe you can save your project as a different version.

You could also replace plugins used once or twice with different plugins used more times. You can find them easily on VST Plug-in Manager - VST Effects tab, clicking on last column - Instances sorts the plugins on how many times used. Same goes for VST Instruments

@djgraver: I will ask, but I think it’s unlikely that this makes it to Cubase 9.0.

sounds very much like plug-ins not releasing the slots, which require to restart Cubase in order to free them up (usually it’s not required to restart the system, though).

@mart: In 9.5.10 the difference will be small, 4-5 more slots available.
Still no list of affected devs, I’m afraid, I’ll check into that again.
Stability should not be affected, but gradually introducing this is meant to monitor any unexpected behaviour that should come up.

Thanks for the update Fabio. If there are known plugin manufacturers who do not use Static linking then it’d be good to name and shame so we can as users try and increase numbers of complaints on their forums/customer support.

Over at the UAD forums some users chimed in to do some research on what plugins work and which don’t, once this weird limit is reached:

https://uadforum.com/support-troubleshooting/32459-cubase-|-windows-|-uad-limited-amount-plugins-only-5.html

It is problem on my side or developer ?

btw. i can load any amount of jBridge plugins. but, if i trying to load same plugin without jBrdige, i have this issue

The problem is not on your side, FLS slots should be released as soon as you remove the plug-in(s). Or at least when you close the project.
I’m afraid I’ve never heard of jBridge in the scenario you describe.

I also definitely have many more issues on Cubase 9/9.5 than on 8.5. At the moment I’m stuck using older versions of Cubase just in order to get my projects to load properly.