VST Expression: Articulations to slow

Hello Everybody,

is there an Option to send Keyswitches (etc.) BEFORE the Note/Key is sended? My Problem is, that the articulations are delayed by one Note. This Time it is Requiem Pro (Kontakt 4) but it’s not the only one. The only Option I see is to Change the type from Attribute to Direction. But: I don’t want this. Do you have suggestions? HELP!


Has no one an idea? STEINBERG?

I don’t have this problem.

Articulations are sent properly - and sound correctly.
Using Kontakt, EWQL Play 4, and many others.


Hello HughH,

thanks, but this does bit help! The Problems are Not with ALL Libs! Mist Kontakt Libs work propably e.g. Storm Choir but not Requiem Pro and sometimes vsl. I guess the ks of Requiem Pro react very slow. So there should be an Option to Controll VST-Expression…




wouldnt this be more a question for native instruments?
or the library developer?
since all libs are not affected it would seem to be a problem with the way the library scripts are written not
a cubase or kontakt issue.

No! Defenetifly NO!
Sure: There seems to be an issue with the Lib or Kontakt! But Cubase should offer this option. The reasons for problems with keyswitching (etc.) are so various, a DAW with this “self-conception” has to offer such solutions.
I have solved this issue with MIDI-Sends. I’ve used two MIDI-Sends with the “MIDI-Modifier-PlugIn”. One for the KS witch negative Delay, one for the “music” without Delay. It works!

It happens often to me with VSL instruments Pro. Maybe Cubase should have an option to ensure key swiches are effectively placed before the note events in the MIDI buffer.

Using the Midi modifier plugin is a good idea too! I have to check that.