VST instrument plays when Cubase plays with no data in track

Hi guys,
For the life of me I can’t find the solution to this problem. I’ve had this issue before and never found the source of the problem. On working on some older songs (1990s) and these songs did use any VST instuments but in one of these older songs I just purchased Spitfire’s MG Soft Acoustic VST. I add the track to my project, select the channel and when I play the project this guitar VST is what sounds like, playing random notes. As long as the track it’s it is recorded armed or in monitor mode the VST instrument will play notes while the project is playing. If I solo it the notes don’t sound entirely random but I don’t understand what is trigging these notes. There is nothing in the track for it to play.

I checked some setting that I thought might be the issue like MIDI Thru mode being active but that wasn’t it…
Any clue use what is trigging this instrument to play despite there being no midi data in it’s track?

That tells me that there might be a MIDI device sending MIDI events to that track. Could you post a screenshot of Studio > Studio Setup and activate MIDI Port Setup in the Devices list?

Thanks for trying to help out. I really appreciate it. Ok I’ve attached


what you requested.

Chris

Is the MIDI Input on the track in question set to “All MIDI”?
I see you curated your “In All MIDI” from the screenshot above which is great.
I would start by trying to rule out that one of the MIDI ports is sending something when it shouldn’t. Start by setting the MIDI Input on the track to “Not connected” and if the problem goes away, continue with each port individually that are a member of the “All MIDI” selection.

Hi,
No the track is set only to the port that the master keyboard is on.
I forget what the “In All MIDI” is actually for. I did set that about a year ago but when I look at it now it doesn’t make any sense that it’s on port 4 which is a DM-5 drum module. I would think it would be enable on port 1 and port 2 which are keyboards that can trigger the VST. Hmmm.

I have about 15 midi tracks that are all muted. These were the tracks that were rendered to audio. Just for the heck of it I went through every midi track and selected Not Connected. It didn’t make a difference. Hmm Confused.

You don’t have a chord track setup or anything? By default that will monitor through any tracks you have enabled.

If you put a MIDI Monitor on the MIDI Inserts for that track (In the inspector) it will show you what data is coming through which may help you track down the culprit?

1 Like

Hmmm Ok thanks. I’ll have to check this. I’ll check this and report back. It may take a few more days as I just got out of surgery and I’m not near the studio PC but thank you guys.

I’ll look into this and report back.
Chris

Sorry guys for the late replay. I’ve had surgery and could get around. Ok Mr. Skijumptoes I DO have a cord track. So do I just mute this cord track or is there maybe a configuration change that may be able to be done to correct this?

If ChordTrack is the one sending MIDI to the track then yes, muting it will stop the notes being sent.

Furthermore some MIDI insert effects like StepDesigner can create notes. Check also that section of the track.

Reading the OP back again, one other thing struck me…

I had some weird similar sounding behaviour with Retrospective Record, whereby I’d get weird playback of notes or chords happening - stuff that I realised I’d been practising/doodling with earlier, whilst Cubase was in ‘Stop’ mode. That led me to think of RR. So tried emptying buffers (in Inspector or via Transport menu) which didn’t help and it has to be said was starting to drive me nuts.!

I checked C12 in a similar way to C13 and that gave me no problem. RR was working correctly and as expected.

So, did a ‘Install Again’ process of C13 from Steinberg Download Assistant; problem still happened. Then did the ‘trash preferences’ trick (renaming Defaults.xml and RAMpresets.xml) and so far, thankfully, my situation seems to have settled.

In summary - if the OP complaint is down to already indicated ChordTrack/Midi Inserts use, then fine, problem over.

If not, then maybe RR is another possible source… Ok, trashing Preferences helped in my case; but there could yet be some underlying glitching with the RR mechanism that’s crept in for C13, needing attention.

1 Like

Hope you’re doing ok after surgery.
And yes you can mute the Chord Track is the easiest way. There’s an additional selector on the Chord Track which dictates where the notes go, by default it will go to any monitored (Record enabled) tracks.

Muting simply stops that destination.

1 Like

Thanks man. I appreciate you taking the time to reply here. Muting the cord track did the trick but I don’t understand why it should have to be muted in the first place…but it did work.
I did suspect RR also and cleared the buffer for it. It didn’t make any difference though.

Thanks for the best wished on the surgery. Overall the surgery went well but there are some issues still lingering and getting me a bit upset.
Thank you as well for the efforts to reply. I did mute the cord track and that took care of the problem but I’ve had a lot of strange things happen that drive me a bit nutty. Inconsistent things. Like in Comp mode. Sometime it works as it should other times I have to manually mute each take before recording the next take. The weird thing is if I set it up with a loop and just leave the recording on it will usually work correctly but if I do one take at a time I have to manually mute the previous take otherwise it will play back the last take as I record the new takes.

When I first met the Chord Track I also struggled to understand how it works. So maybe this will help a bit:
Usually you instruct a MIDI/Instrument track where to receive MIDI data from through the Inspector settings.
With Chord Track, however, this is done by either setting a track to monitor/arming a track or by chosing the destination of the Chord Track in the Chord Track itself.
This works vastly different from any other concept of Cubase and can thus be confusing. Anyway, the Chord Track needs to be stopped sending its data, and that does not happen by telling a track to stop listening to it but by telling it to shut up = muting it.

1 Like

Thank you Jonny. Very informative. Yes it was very confusing and the manual isn’t always a help with stuff like this…so thanks!
C