VST instrument recognized as effect rather than instrument

Hi,

I just updated Cubase 7 to Cubase 10 pro.
I have been using IK Multimedia software synthesizers in Cubase 10 by bridging them with jbridge, and have had no issues at all.

Now after installing Cubase 10 all my VST instruments show up in Cubase 10 just fine except for IK Multimedia’s Miroslav Philharmonik. It shows up as an effect and it says ‘vendor unknown’. all the other IK Multimedia instruments show up as instruments and the vendor is shown.
I can load Miroslav Philharmonic as an effect on an audio trakc but can’t use it, since it needs to be on a MIDI or instrument track.

Any ideas what is going wrong here?

thanks a lot in advance!
Lars

Trash the jbridge files and jbridge it again. This will force a rescan and might fix it.
BTW the latest IK version is 64 bit and doesn’t need jbridge IFAIK.

Hi, this might be an option.

I have Miraslav Philharmonik CE and recently spoke to IK Multimedia asking if there was a 64 bit version (to avoid the need to bridge which seems to be getting less reliable). Their answer was no, but that the sounds could be imported into Sampletank 3. They sent me an email with the method of doing this, I remember that it was fairly straightforward and it’s working.


.

Thank you very much. I am aware that Sample Tank 3 is 64 bit, but I have not purchased the upgrade as I am still happy with the sounds of Sample Tank 2. Only if everything else fails I’d consider buying the Sample Tank 3 upgrade.

Thank you very much!
This is very interesting, I did what you suggested, deleted the bridged files and bridged it again, however this time I forgot to check the option to NOT add ‘.64’ to the file name, so, now the bridgjed .dll file is named ‘Philharmonik.64’, and it turned out this worked out fine, no problems. So, I concluded, the file just needed to be bridged again, but since I don’t like that filename having the .64 in its name, I deleted again, and bridged once again, this time I did check the option to not add ‘.64’ to the filename, and strangely enough, the problem now was back, it was not recognized as an instrument. I also tried manually renaming the bridged .dll and .txt filed by deleting the .64 at the end, but same issue.
It seems, this only works as long as the filename contains .64 at its end.

EDIT: I just did some more experimenting with this, and it seems the plugin can be renamed to anything and it will be recognized as a VST instrument (I just renamed it to PhilharmonikM), however, if the name remains unchanged (‘Philharmonik’) it will not be recognized as a VST instrument, but as a VST effect with ‘vendor unknown’.
This only happens in Cubase 10 for me, not in Cubase 7. Isn’t that odd?

Does anybody else have any input on this issue?