VST Instruments load but they don't receive ANY midi at all. They don't work

Hi,
A while ago stopped using Cubase 10.5 because I couldn’t find a solution for my problem. Basically:

  • Cubase receives midi input
  • The track receives midi input
  • I can record midi on a track
  • The instrument loaded in the instrument track doesn’t receive ANY midi. I tried with Kontakt, Spitfire player, Omnisphere, Groove Agent and others. Is not the plugin. Is the DAW. Even opening Groove Agent and hitting the “virtual pads” in it…it doesn’t work! Very weird issue…

I can work with other DAWs so this is a weird issue on Cubase. I have deleted it with cleaner apps (to remove all preferences), reinstalled…several times…but it is not fixed yet. Deleted all preferences and all of that, still…it doesn’t work. Basically ANY virtual instrument plugin WONT work…

Does anyone have an idea what could it be?

Some months ago I tried Cubase 12 (demo version) and the issue was solved. It’s something about Cubase 10.5.

I never had an issue with this in 10.5. I wonder if anyone else did? I’m on 12 now so I can’t look again as 10.5 has been removed