VST instruments not echoing back to My midi Keyboard

I will try to be brief

My midi keyboard is the Yamaha Genos
In Cubase 12 professional after creating an instrumental track with Haleon SE applied or Groove Agent 5.1
I open up the virtual keyboard, and I could click away at notes and I could hear them
When I use the Yamaha Genos, I can record the notes, but I cannot hear them being played back LIVE. I can hear them in my headphone after recording.

The Yamaha Genos Midi data is being sent, but I can’t hear what’s coming back live

Any suggestions?

I’m not entirely sure what your problem is, but maybe you should enable the monitor button?

Already tried that my friend

I highly doubt it’s my Motu M4 interface

My Yamaha Genos is plugged directly into the computer via USB all of my projects are normal and can be heard. Is there any way I could use an audio track for Haleon or groove agent?

Thanks for getting back.

I am inserting many pictures from my Cubase 12 professional screens. Maybe Martin J. could help out.

Pictures 1

Pictures 2

Pictures 3

As shown in orange in your screenshots, it looks like something about your Control Room isn’t configured correctly. Press F4 and take a look at that tab.

The screen that says stereo out which is not connected is incorrect. It was connected my error in the photo. It is a screen. I always check when I open the studio. I was just in a rush to take the photos.

It has to be something else-

Maybe it’s a Yamaha Genos keyboard

Monitor button is off in your screenshots as well.

Monitor Button-was turned on-still no audio coming out. when I play the Yamaha Genos, for the selected VST instrument, the instrument gets recorded, but with no sound. on playback, I could hear what I recorded photos below.

More pictures

So does anybody want to take a shot at this?

Try clicking the image MIDI Reset button to the top right of the interface. Do you hear anything when you play your keyboard now?

In Cubase’s Track Inpector, click All MIDI Inputs and try to set it to the Genos only.

If that doesn’t work, please take a screenshot of Halion Sonic SE’s interface and its Mix tab.

I tried to set Genos on the input, but it’s not available even though it’s available on my audio connections this, I don’t understand.

Uploading: 0C187BEF-B697-46AD-861D-00887E2062DD.jpeg…
Uploading: 332A9E3C-C122-4020-BF21-6372E26D394D.jpeg…
Uploading: E9EF419C-8D3C-419A-B60C-418A492E55F1.jpeg…

Please note that on the Halion SE photo I did have the volume picked up for that vibraphone, which is not reflected in the photo.

The midi reset was pressed as requested, but still no audio out


Chord Pad’s Input is set to All MIDI Inputs, which could filter the MIDI data.

Are you sure you play in the range of the Vibraphone?

Can you see incoming MIDI signal to HALion Sonic SE?

Thank you Martin for joining the thread in finding me a solution currently I’m at breakfast, but as soon as I get back we could all get working on this. Thanks so much - talk to you soon.

Alan Russell

Martin. How can the Chord pads midi setting be changed?

As an arranger I am very aware of the range of the Vibraphone, so I know I’m playing that correctly within the keys of the Yamaha Genos. As an arranger I am very aware of the range of the Vibraphone, so I know I’m playing that correctly

I see no communication between the genos and the keyboard at the bottom of the Halion SE screen but if I record the instrument track with a Vibraphone, there is data being written to the track but I can’t hear it. I can only hear it on playback.

Thank you for your ongoing help. I hope to get this resolved. I have a very active recording studio and would like to use those Halion libraries.

Alan Russell


Studio > Studio Setup > Chord Pads.

The MIDI track in the picture is showing the MOTU interface the MIDI input and not the Yamaha keyboard.


On the audio connection screen, I cannot seems to get the Yamaha Genos to its own device input segment of that screen

When I created and configured, the Yamaha Genos, for Cubase 12 professional, the output, was digital workstation 1. I have used that on the Halion screen, but still the same problem.

The other inputs that I created for the audio connection screen, I scannot seem to bring up for the input on the Halion instrument track.

I am able to transmit data to the Halion screen, but not hearing any sound live and only hearing the recorded track sounds on playback.

I have searched the Internet for a solution to anybody successively using Halion or groove agent with the Yamaha Genos and cubase professional 12. I have found none- maybe you guys could ask others.

All of my midi and audio tracks for play and recording work perfect with the Omaha Genos the only problem I’m having arecVST tracks.

Any other suggestions

Thanks for hanging in there with my inquiries


Try to fix all suggested. Does it work? If not, attach new screenshots with the current (fixed) state, please.

Martin-still not working. Are there any particular screens that you would like to see? Just let me know I will get it to you ASAP.