VST Link Sync problems

I have had a link between two computers “working” for some time where I can transfer audio files in real time, but today I needed to have the computers start at the same time, and I then found out that the link did not work properly.

Here is the setup:
Master: Mac with RME Hammerfall Raydat (PCIe), Cubase 5.5.3
Slave: PC with Creamware Pulsar (PCI), Cubase 4.5.1
ADAT used for link
Two mono and three stereo busses (8 channels all together). Mono 1 is the link carrier.

When I connect an optical cable from ADAT in to ADAT out on Creamware audio card the “Self test” works with no errors. The yellow and blue send/receive signals flashes in the Device set up panel.
When I connect an optical cable from ADAT in to ADAT out on the Hammerfall audio card the “Self test” works with no errors. The yellow and blue send/receive signals flashes in the Device set up panel.

When I connct the two computers with two ADAT cables (in/out times two) the yellow and blue light still flashes in both Device set up panel dialog boxes, but the “Self test” now only gives errors.

I can however transmit audio on the two mono and the three stereo tracks back and fourth between the computers, no errors in the transmission, but I can not run both transport panels (cursors) from one computer.

Sample rate, bitrate and tempo is the same on both computers. The Master MAC sets the Sample and bit rate for the Slave PC.

Also Cubase 4.5.1 on the slave computer won’t restart. After save/shut down/restart Cubase - Cubase crashes. I then must remove the two ADAT cables and restart Cubase. Then Cubase starts ok and I can reconnect the cables. This is an EACH time occurance.

Any idea what could be wrong? Anybody?

Do you enable Sync on the Transport?

OMG! That simple?

Yes! it works now. Guess the “Self test” is for one computer at a time time test, and not ment to test computer to computer, right?

Got MIDI transfer working! Great!

Still haven’t figured out slave as effect rack though. Audio is going out on master through audiotrack “Send” and in to the correct slave track where effect is inserted (as “insert”). “Send” in master audio track is activated and “volume” bar is at max. Monitor is activated on audio slave track. VU meters show activity in the correct channels on both computers, but signal is still unaffected by the inserted effect (in on position). Guess this is also a “one button I haven’t found yet” problem.

Sure Direct Monitoring isn’t activeted? Why enable the monitor button on the slave track? Should be off for playback.

Because if it´s disabled, the signal from the master (Send) track will not get the insert FX of the slave track.

Yea, manual agrees with thinkingcap.

I can see the signal is coming in to the effect plugin in the slave audio track and if I set the out bus on the slave audio track to “Stereo out”, insted of one of the VST system link outs, I can monotor the signal WITH the effect, so signal is ok at least one way. If I however set the out bus on the audio track (with the effect) on the slave to a VST system link out and monitor from the master, the audio is unaffected by the inserted effect in the slave.

I have tested all the VST system link ins and outs on both the master and slave. The all carry audio signals perfectly.
The “Send” is turned ON in the master audiotrack, and the volume slider is all the way up (on). What could be wrong?

To be honest I´m not sure. I thought this was a sound card setting? No such thing on my sound card i believe = ???
Where is this function located in Cubase?

It’s in Device Setup-VST Audio System.

I don´t have that option in my VST Audio system. What I have is:
Choice of ASIO driver
Tick box for Release driver when application is in background
Numbers for Input and output latency
Numbers for sample rate
HW pull up /down which is set to Off
Choice for Audio priority (Normal and Boost)
Tick for Multi Processing which is set to On
Choice for disk preload which is set to 2 seconds
Tick for Adjust record latency which is set to On
Choice for Record shift which is set to 0 Samples

Thats all!

Next sub-tree down.

Thank you for your patience. However that is grayed out in my system on both master and slave. So I guess the sound cards does not support direct monitoring. If this is the correct conclusion then the problem is not direct monitoring.

Send on master works great if I use an FX track on the master computer. When I use send through VST link bus to the slave computer the signal is unaffected. I can however see signal in the VST link bus out on the master, in on the slave, out from the slave and in on the master again, but unaffected from the plugin. As mentioned before; If I monitor at the slave I can hear affected signal. Strange.

If I add another track on the master and set the input to VST link output from the slave, I can hear processed signal. But the manual does not mention a second audio track on the master, only the Send set up on one audio track. The processed signal on the second audio track also have a lot of latency.

Yeah, was just a WAG. :wink:

I’ll think on this, right now it’s making my head ache trying to picture it. :laughing: