VST Live 1.1.54 MTC Sync doesn't work properly

I try to sync VST Live as Master with Cubase Pro 12 (latest version) using MTC.
However there are issues with the sync when I hit start in VST Live.

In the examples I use 2 Songs - the 2nd song is using the new TC Offset functionality.
I am using the macOS IAC driver for the sync via MIDI Timecode.

Song 1

  1. Start the song in VST Live with Part 1 (Counter) => Cubase starts delayed
  2. When I hit stop and run it from that position => both are in sync
  3. When starting with Part 2, 3, 4 => both are in sync

See video - I have activated the click on VST Live AND Cubase - so you can hear the delay:

Song 2

  1. Set TC Offset to 00:01:47:19.
    In the Cubase project this timecode is shown for measure 62.
    Tempo was set to 160 on both projects.
  2. Start the song in VST Live with Part 1 => Cubase starts delayed
  3. Same for Part 2 and 3 => Cubase starts with the same delay as for Part 1.

See video (also with metronome click):

Will check, thanks for reporting.

Great, thx a lot :slight_smile: !

Hi @musicullum

I have downloaded v1.1.60, the issue is still there. Did you figure out why this is happening? Is there a workaround? Unfortunately, currently VST Live is not usable for me because of these sync issues.

Top of our list, but couldn’t make it into 1.1.6, sorry.
We will most probably release another update soon and there it should be fixed.

1 Like

Correct, fixed with the next update.

Where - Cubase Project Start Offset? How is that supposed to sync to bars/beats?
I tried 00:02:00:00 at Tempo 120 which should match bars/beats. It was slightly off and we fixed that.
Note you should have fps set to 30. Did several tests and it is more precise now as well.

Great! Thank you very much!

  1. I have set bar 62.1.1 in the Cubase project as new song start (as an example), also changed the tempo to 160

  2. Then switch the time format to Timecode:

  3. The TC time is shown for bar 62.1.1 (= 00:01:47:19):

  4. In VST Live set TC Offset for song 2 to 00:01:47:19 and tempo to 160

ok, will check that as well!

Ok, got it.
So we added a frame rate setting in the trigger list view. Note: this is for the whole project, while MTC Offset is per Song. So you can trigger Cubase Arranger Parts by setting VST Live MTC Offset to the according time - interesting approach :slight_smile:
You will probably have to re-enter the TC offset anew, and save again with the new version, there was a frame rate error.

This is working perfectly with 1.1.63 :sunglasses:

Tested also via Midi Network, very accurate. Awesome work, thank you very much!

Next step: sync VST Live to incoming MTC :grimacing:

1 Like