VST Midi out of sync when looping


hope somebody can help me solving this issue:
I am using a VST to trigger another VST on a different track.
When looping is activated, only the first run through the loop produces evenly spaced notes (in this test case 16th are sent from an arpeggiator VST).
As soon as the loop starts over again, the Midi data is completely mess, i.e. notes are not in perfect 16th anymore (“out of sync it sounds like”).

Do you know if this can be solved?
Already tried setting Midi time info and tried various Midi generating VST. All have the same issue.
Also if I record midi on the receiving track it shows perfect 16th afterwards.
this is only occurring when looping is enabled and when loop restarts after first run (llooping deactivated, no issues)

Thank you,


I have the same issue… and (in my case) it’s not related to MIDI generating plugins and/or the routing. I recorded the MIDI generated by Apache… but that didn’t help. It happens (in my case) with any synth.

Another user wrote that the first MIDI note vanishes in the loop… but I didn’t check this info yet.

What MIDI-Generating plugin’s do you use? Maybe you have one that could be interesting for me.

I tried with Nora, Kirnu Cream, Thesys, Riffer
First note is also sometimes lost on my end

Steinerg, any hint on this? Is it normal?

Hi. Have been struggling with very similar issue when trying to sync external hardware to Cubase. Try to uncheck the “Midi Clock Follows Project Position” box in Project Syncronization Setup -> Destinations.

Thank you for the hint, will try that. I just saw in the Cubase manual, that the option to follow project position can introduce weirdness on some older midi devices.
(it is only needed to sync entire arrangements to cubase, not important for e.g. my usecase of using an external step sequencer which is running in some bar loop)
However, not sure if this is applicable to my usecase, since I am fully in the box (no external midi involved)

Anyway, for my in the box issue, I did also observe the following earlier, since my timing in between different notes was off after the first loop:
I was using a large buffer size like 1024/2048 - played around a bit and the off-timing got better if not vanished completely when using lower buffer sizes like e.g. 256 or 512.
I felt like at buffer sizes >1024 timing gets weird somehow.


Update: forget about below - timing is still wonky as sh*t.
This is relly not funny, cannot use any midi VST plugin (arp, sequencer, etc.)

@Steinberg: is this really not possible to use VST midi plugins with proper timing?

Ok, so finally found something wrt my particular issue, controlling a VST via another VST Instrument (generating Midi):

In my case Asio Guard is enabled, if disabled the issue vanishes - but thats of course no solution, so following:

Since the sound-VST needs to be configured Midi-Input of the midi-Instrument, record or monitoring must be enabled as far as I know to receive Midi data.
Now: If I set the track with the Midi-vst to record/monitor as well, the sync is stable also when looping in the project occurs.

Not sure why this is necessary, and why it works without doing that when not looping. maybe Steinberg can comment whats happening?

This is a user forum, not the official Steinberg support.

Ever tried to reach out for Steinberg Support? I guess not.

Why wouldn’t and shouldn’t Steinberg comment in their own user Forum to help out more than one person?
Apart from that, they sometimes do comment in the “user” forum.

And if you ask me, they should intensify, because Cubase is well known for the least supported DAW in terms of lacking support by the vendor and community as well. So, if they want to persist in future, Steinberg is already well aware they have to improve.

I’m having a very similar problem to yours. In my case I use LFO Tool as a MIDI-triggered volume shaper. If I activate the loop, only the first run recognizes the first trigger. As soon as it starts looping, the first one is no longer recognized unless I move it a bit off the grid. I feel like my problem and yours might come from the same underlying issue.

Here’s a video where I demonstrate this problem: https://youtu.be/CZx1BQyIU38

I’ve tested this in Ableton and it doesn’t have this issue.

I just came searching here after having a problem playing with Audiomodern’s Riffer and looping resulting in it being another step out of sync every loop.

What worked for me was adjusting ASIO-Guard from “High” to “Normal” (I must have put it on High to solve a specific problem some time ago, and then forgot)

Your mileage may vary, but nonetheless, things should stay in sync no matter what setting ASIO-Guard is on,

thanks for letting us know.
I also changed and disabled ASIO guard, but did not do it for me.
What was significatnly improving for me: decreasing ASIO buffer size.
Before I had 1024-2048, and I feel the Issue is gone (or small) with lower buffer sizes (e.g. 256)

Maybe you can also check this, because yes I think mileage can vary - in case of Asio guard I somwwhat guess it has to do with how loaded the project is maybe.


Tried everything above including buffer size and asio guard
Still having this issue i can’t get rid off!
Also its a known bug in cubasis.
Does anyone here really solved this??
In my case its riffer but with a real synth too