VST Midi Out

Hello all,

I can’t manage to select the midi out setting of a VST plugin in Cubase 7.5. Midi in works of course, and te same plugin is working with midi out routing in other DAWs, both in VST2 and VST3 version. I found some hints here for older versions using the rack and not a track instrument, but couldn’t find any difference.



Good to know what plug in you’re talking about, also good to put your equipment in your signature.

EZkeys works like a sound module but you can turn on the midi output in the settings for the plugin and then it will output midi and shows up as a source in the inputs for other tracks.

Hello Tacman,

Thanks, I tried EZkeys demo now, same result. I can see when choosing the midi ins of another midi track, that the plugin has a midi out i could use as input there. But I can’t figure out just where I can tell cubase to route that to a physical output. Maybe I’m just blind, for sure I’m confused.

In the track inspector where I normaly choose the physical midi out for a midi track, I need to choose the plugin itself to get the plugin midi-in connected - pretty normal. But then I can’t do the plugin-out routing there of course.

What am I missing?

Equipment Is Cubase Artist 7.5.40 on Windows 10 x64, i7/16GB/SSD, Midi Hardware TC Konnekt 48 and MidiSport 4x4. For half a year now no other problems with that setup.

I’m really not following your problem here :confused:
You say that you can indeed see the MIDI output from that plugin amongst the list of available MIDI Inputs to other tracks (so, go ahead and use it :wink: ), and route the Output of the MIDI track to which you have routed this plugin’s MIDI out, to whatever is available in that MIDI track’s list of available MIDI outputs. What am I missing?

OMG you’re absolutely right. 50% working now this way. Thanks a lot! Seems obvious as soon as you know it.

The other 50% that still don’t work are sysex messages. I’ve alredy unset the filter settings that I know about, but there seems to be another filter mechanism. Hope it’s not hardcoded.