VST / MIDI Recording doubles

Whether I’m recording drum piano organ etc with VST or any other plug-in, I’ve noticed that I am recording doubles. To remedy this I am quantising everything, then going to the midi drop-down menu, selecting functions, and then deleting doubles. This happens whether I use my Roland A/49 or my Juno Gi controller. If I am on the editing page and double click to create a specific note, it only comes up as a single.
Cubase 12 Elements
Not sure why this is occurring, can anyone help?
Thank you in advance

Hi,

Make sure, you are not using 2 types of MIDI driver simultaneously. Open the Studio > Studio Setup > MIDI Ports Setup and double-check, please. You can also attach a screenshot of this window.


This is how it is at the moment what should I un-check,


I un-checked the top row and did a test, success.
I re-checked it and unchecked the second row, success.
I hope it doesn’t matter which one to operate without…

Hi,

Do you have the keyboard connected via USB to the computer and via MIDI to the UR device?

This is my setup.
As you can see I have 2 seperate USB cables permanently plugged in to both keyboards. One goes direct to the computer. One goes direct to the UR 44.
I then interchange the midi-in cables, depending on which keyboard I want to use, as there is only one midi input on the interface.


Since you are connecting the A49 with a usb cable, there is no need to also connect it with a MIDI cable. The usb on it act as a MIDI interface.
Now you can have both keyboards connected at all times.
If your second keyboard has usb connection as well, I would recommend you use that instead of MIDI cables.

1 Like

Thank you so much for your help.
I am away from the keyboard at the moment, but will experiment with these configurations that you have suggested.
I think that the Juno on the right only has midi out but i will check.
keep an eye out and I will get back to you.
Thanks again