VST Perfomance

When I hit F12 it comes up a box VST perfomance

One is for Average load, green colour (how much CPU you use, and I only use 25%)

The other one in blue is Real time peek, means how much you load in realtimes

My Real time peak is going to max (red colour) about every 10 seconds :open_mouth:
what`s that mean ? Is something wrong? :confused:

The average load and realtime load do not show your CPU usage, but the ASIO load. This is how much resources are left before the audio driver fails to load your audio in time. If a constant reoccuring peak is noted in your realtime monitor this means there is one or more drivers on your system interfering with it. Most probable culprit is WIFI, but in fact it can be any other driver on your system.

You can track it down to the problematic driver by disabling them one by one and the verify if the peaking still exists in cubase. Logically some of your systems drivers can’t be shut down so be carefull when doing this. Alternativly you can use any form of proces monitoring tool to nail down a bad driver.

kind regards,

Months and months of this. Pretty sure Steinberg is totally stumped as well.


Great post roel. I have a similar problem on a new Mac pro 8 core. Could it be a Yosemite issue?

You’re not doing anything wrong. This is the CPU load character of Cubase, and it is wobbly, has been ever since SX1 - on both Mac and PC.

Take a glass, fill it to half with water. Move the glass back and forth in the air, and suddenly stop moving it. Look at the surface level in the glass, wavering around.
Play a bit of music with high CPU load in Cubase. Look at the CPU meter, while you stop Cubase.
You will see that the CPU meter in Cubase, and the water in the glass, moves quite similarly - kindof wavy, surging. It’s rather unique to Steinberg’s software. No other DAW does this - but Studio One (which is made by former Steinberg programmers).

Version 8 is the the most CPU-stable and CPU-efficient version of Cubase I’ve seen though. In Cubase 5 you couldn’t go much above 60-65% load, the wobbling CPU load would then reach 100% too often and produce ear-piercing crackles and dropouts.

A single plugin, at the end of a chain, can cause the CPU load to get stuck on 100%, at one time. Next time you try the same thing, nothing may happen. The same plug without a plugin chain, can work just fine. It can also depend on the combination of plugins in the chain. Overall, there’s no consistency to be found. You just hope for the best and keep going and solve things as they come up, roll with the punches.

But I’m no where near using the computer to Max. In the project I worked on today I had two instances of PLAY with silk/ra and an instance of kontakt with emotional piano.

It’s new wastebin Mac pro.

That’s my point above^. Most of the time the CPU meter shows fairly correct load - although wobbly. But sometimes, what you do or load gets translated by Cubase to load the CPU much much more than it should. Sometimes it locks the CPU to 100% load, although you just loaded one small instrument or plugin.

Sometimes, all you need to do is to restart Cubase, load the same exact project again, and the CPU load will be realistic again. If not, you can make a new blank project, and import the data from the first project (MIDI data, Kontakt instruments/multis etc) and it might work like it should again. Or, if you’re unlucky, it will not.

Don’t waste your time trying to find some reasonable or technical explanation or fix for it. There are idiots like me who tries to do that :wink: and people have been trying to find this for over a decade and not found anything conclusive. It’s just the way Cubase is made.

It’s an open forum so every opinion is there for free, but in this case OP has been telling clearly what his issue is, and imho this is not what you are describing Seraglio. Luckily most users experience the same behaviour every time a project is loaded. It’s sad that this isn’t the case in your system.

I would try to find the driver that is causing the issue in OP’s system. Don’t do things if you are not sure on how to recover from it if you break something. In most cases and with some trial and error, you’ll get to know your hardware and how it works, its pro’s and cons, and in the end it youwill probably get it fixed.

good luck,
kind regards,

On Mac there’s barely anything to turn off… I think the best course of action for me is to rewire the kontakt instruments in.

Before you get too embroiled in discovering the joys of buffering/queuing and CPU usage, just try turning up the latency on your sound-card driver. Things get significantly more jerky as buffer size is reduced, and things get much smoother as you increase buffer size. If you don’t have a need for near real-time through-DAW monitoring, then give your computer (and your patience) a break and turn-up the latency.

I’m making an assumption here that you aren’t suffering from interrupt issues from other hardware drivers.

Yeah personally I’ve been using Cubase for years and I’m used to moving the buffer up and down - since Cubase vst4/5 .

I write a lot of library/trailer music for publishing companies and was really hoping to get much better performance out than what I’m getting. The real time peaks are a killer.


Here’s a utility that might help you identify your ‘spike’ problem, see here:


Good luck.

So I slaved Reaper to Cubase…

and I loaded up emotional piano in reaper and kept and eye on the performance meter in Cubase. When I started to play there didn’t seem to be a huge amount of difference… I was still getting pretty high real time peaks with only one instance of kontakt with an albeit fairly large piano patch loaded (0.71Gb) .

There was then a click - much like a cpu overload glitch and then my real time peaks fell and aren’t reading anything much at all and piano is playing fine…

So I’m thinking rewiring larger instruments through reaper is a way forwards for me at the moment.

I saw he wrote “My Real time peak is going to max (red colour) about every 10 seconds”, without putting any considerable load on the computer. So I wrote what I feel certain is the general cause for that, in Cubase.

I’ve felt like a prisoner in this “It’s gotta be something wrong with your system. Did you optimize? Got the latest drivers for everything?”-policy. I’ve heard that ever since Windows 3.11. I used to believe it was true too.
But it doesn’t work. Don’t matter how much we chase imaginary mice around our own systems, it never fixes this - with or without official support.
If this was the system condition or config, then the same exact problems would show up in other DAWs on the same system/installation. And they never really do. This is Cubase’s personality, that causes this problem that the OP describes - though not every single case, naturally.

I’ve grown stark in my posts about these things, and I do understand it can leave an acrid taste in ppls mouth. I don’t enjoy it - really. I just don’t want other people to get stuck thinking it’s their systems, tearing their hair out in frustration looking for false problems, which they’ll of course never find, but be blamed for still. I did this for so long. shrug

Well not quite: There is Time Machine, Filesharing, Airport, Bluetooth and Energy Saver.
I guess you know that, if not… :wink:

Yea those are all true. It’s not on a windows scale though.

This is NOT normal behavior for Cubase.
I know that over the years I used to get ‘out of memory’ related overloads and if I restarted Cubase and sometimes had to reboot the computer it would fix it.

I just installed C8 on a new iMac 3.2Ghz Quad with 16GB Ram.
My audio is playing from an external Thunderbolt drive, Samples loaded on internal.
Running mostly UAD Plugins (Quad Apollo at 65% load) and low latency.

Project I was just working on has about 20 instruments loaded: Halion Symphonic, several (were very CPU intensive in the old days!) Stradivarius Violins and Gofriller Cello (Kontakt based) Halion 5 Mellotrons and a Grand Piano plus 20 or so audio tracks.

The Green average load is sitting in the 15% range for most and the Blue is barely on…like 5%.
WHEN I HAVE AN INSTRUMENT IN RECORD, the load is much higher but still lower than 20%-35%.
As soon as you take it out of record, the load drops way back down for playback.
I even held the Sustain pedal down and did a big 3 Octave gliss while all the other instruments were sustaining notes and the CPU barely blipped.

And this was with iTunes, Email, Messaging, Safari, Bluetooth accessories and remote control of an Eventide H9, UAD Console with realtime headphone Reverb on all running in the background.

I used to run lots of Kontakt based Stormdrum, RA, Choirs, Colossus and seemed to have more issues then.
That was on a PC in 32 bit for the most part.

Whats the biggest sample you got loaded there JohnMarkPainter?

For smaller/mid sized stuff it’s not performing too badly… but for something like emotional piano at 0.71gb it just bails. I can get cubase to glitch with one instance. On 10.6 on a 2010 mac pro I was able to load the same piano.

I’ve rewired cubase to reaper and thats currently solving my problem because I can load the samples in Reaper but it’s not ideal.

Steinberg support told me to delete pref files and contact native instruments… so i’m going to see if I can reproduce the same problem with PLAY. Though I’m not sure if any of the sample instruments are that big.

OK so i’ve found the issue my end. It’s Yosemite/Cubase compatibility.

I ran emotional piano running under OS 10.6 on a Mac 2010 32gig Ram running cubase 7.5 and there was no real time peaks.

I ran emotional piano under Yosemite on the same mac running cubase 7.5 and then C8 pro and I got the real time peaks.

I’m also suffering from terrible realtime peaks on Mac with 1 or 2 instruments loaded. I’ve had to off load everything to VE Pro 5.