VST performance issues after upgrade to C6

I just upgraded from Cubase 4 Studio to Cubase 6. I also did a Windows 7 upgrade from XP as a part of the process. That part of the process was all smooth, however, when I open my Studio 4 projects now, I am having tons of stuttering - the VST performance meter is peaking. They played without issue on the previous OS/version of Cubase I had.

Some other nuggets.

Just opening a project (song is not playing), CPU usage in Task Manager is 50-55%.
Just opening a project (song is not playing), VST Performance meter is at approx 75%

When the song is played, the VST Performance spikes frequently, and hence the stuttering.

I installed Windows 7 Home Premium 64 bit
Cubase 6 32 bit
HW is Intel Core 2 Quad 2.66 GHz

Audio interface is a MOTU 828 mk2

I have tried:

  • Multi-processor setting in C6. If unchecked, the problem is worse
  • Power boost setting. No observable effect on stuttering
  • Different buffer size settings. Can influence the stuttering, but cannot find a setting that works enough
  • The legacy 1394 firewire driver
  • Switching between the MOTU ASIO driver and the generic one. The generic one seems to be a little better, but does not resolve the issue

The variables that have changed that now result in much slower performance are:
Windows 7, the MOTU 828mk2 driver being used for Windows 7, and the Cubase version itself.

Any help diagnosing this further would be appreciated, or anyone that has experienced a similar issue and resolved it will be greatly appreciated.

just try to use 64 bit version of Cubase on 64 bit platform.

Have you selected WIndows classic desktop?..disabling Aero can help.
Do you have hyperthreading on?..sometimes off is better though not always.

If you have plugs & vsti on a project then just opening a project will give you cpu use as you’ve pointed out…are you saying this useage is much higher than on your old system?

Rework the Win7 energy options.
In my case, Cuba6 changed the options but forgot the USB, maybe there’s something equivalent for FW,
so change the energy option for FW to “not energy save” (you have to create your own energy plan).

For every Cubase upgrade I make, some plug-ins always stop working one way or another.
Even though the way I usually notice it is when they cause a crash or fail to load altogether, I guess there’s nothing that prevents them from just performing a bit worse instead.

I recently did a similar upgrade, XP to Win 7 and C5 to C6 but along with a new system, so I can’t really compare the same way you can. Here everything runs super smooth though.
I trust that you’ve already gone through the process of switching your plug-ins on and off one by one while keeping an eye on the performance meter?
Have you installed Studio 4 under Win7 to see if there’s any difference in performance? Otherwise that’s where I’d start.


Thanks - disabling Aero has bought me some headroom. Much appreciated.