VST perfromance - does this seem right - solved!!!

Hi All,

64 bit windows 7, 3770k i7 3.5gz, gigabyte mobo, 16 gig ram, RME UFX at 2048 samples, Cubase 7.5.20

I have the latest USB, video and every driver imaginable, tweaked out powersaving plan, tried with ASIO guard on and off. .

I have small 5 track 24 bit /44.1k project using the following resources

live tracks

  1. 1 instance of EZ Drummer 2
  2. 1 instance of brainworx rockrack
  3. fx track with S-Gear 2.41 on on it
  4. master bus with exmix 2

frozen tracks

  1. i track with Amplitube 3 frozen
  2. 1 track with nectar 2 frozen

With just this my average load is almost 50% and my real time peak meter goes just over 50.

My windows performance shows an average use of about 9% across the cores, but core 1 is a little high hovering around 50%.

I feel like I am not using much but can barely scale above this.

Update

Ignore my thread! I had inadvertently throttled down CPU performance!

Same here with almost the same specs. 5-6 instruments with a couple of valhalla reverbs.

It got a little better when i disabled the Asio Guard.

Welcome to Cubase :slight_smile:

Remove the plugins until you see your load change, then you’ll know how much each one is eating up. See if there’s a setting you can tweak on the offending plug-in. Raise your buffer (Usually what you need to resort to).

Hello,

Are you running Cubase in 64 bit? If so are you only using the 64 bit version of those plugins?

Thank you

Yes 64 bit Cubase and all 64 bit plugins. This was running at the highest latency. Doesn’t seem to be using all the cores.

Hello,

In Cubase go to devices, device setup. VST Audio system. Looking at the bottom section you will see your advanced options. Can you run me down through your settings?

Thank you

I’ll report back later tonight.

Have you disabled core parking?

https://www.youtube.com/watch?v=pl3u9eiskM4

Hello,

Disabling advanced power-saving and dynamic performance options for the cpu is a good optimization. Here are other things to consider:

https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/optimizing-windows-for-daws.html

Thank you

Thanks, I have applied all of these tweaks. I am pretty fanatical about the PC and have my DPC latency down to under 500 when cubase isn['t running

advances settings, audio priority: normal, multi processing and ASIO guard checked. Cubase Power Scheme is not checked. I created a custom power scheme that went a little deeper than Cubase’s Power Scheme. Disk preload 2 secs, adjust for record latency is checked. 0 samples Record shift.

Disabling ASIO Guard doesn’t make much a difference.

DPC latency without cubase running hovers around 60-80. With cubase on it goes to the 500-600 range.

For kicks, I just downloaded reaper and with the same exact plugins loaded I am getting 10% CPU utilization!

Hello,

Before creating your own power scheme did you try checking the Steinberg power scheme box?

Thank you

I did try the Cubase power scheme first with the same results. My power scheme is basically the Steinberg Power scheme with their addition of not having USB able to go to sleep mode. The difference is striking from Reaper. I am a long long time Cubase user, but can barely use my plug-ins. I also tried deleting my preferences last night and that didn’t make any difference.

Threads like this make me nervous, literally just bought upgrade to 7.5 from 5.5 and dreading seeing similar results. It just doesn’t make sense why Cubase 7/7.5 would ASIO overload soo easily with low cpu consumption yet Reaper works perfectly fine on exactly the same system setup. Especially given that we’re talking about RME audio interface here, sound drivers don’t get more stable than theirs.


I take it you’ve done all the energy saving disabled tweaks in bios too right. Also have you tried running Cubase with Windows Aero acceleration on and off to see a difference?

I have done all the bios tweaks. I believe I am running with Aero on right now because for Windows 7 that is what is preferred.

I have used Cubase since the Atari ST days. I have been tied up with work and family the last few years and haven’t been recording in earnest as much as I would have liked to. I am now hunkering down again and starting to deep dive into things. I find that Cubase is adding a lot of overhead. For example if I play BFD3 standalone, I can comfortably play my edrums at 48 or 64 samples. Loading one instance of BFD3 into an empty project enduces pops at the same latency.

I supposed I could uninstall and reinstall everything. I have a ton of plugins I have bought over the years, but I would think that should not matter if they are not loaded into a project.

I also have a UAD card. Maybe I will try to disable as yanking it doesn’t appeal to me right.

Also seems strange that simply loading Cubase causes dpc latency to jump from 50 to 500. Is that checking with ‘DPC Latency Checker’ , or ‘LatencyMon’ ? If its LatencyMon then I wouldn’t worry too much as that programs meant to be run standalone without other audio software running.

Whats the performance like in a project using totally different plugins to those, still get the same ASIO overload at similar low cpu levels or is there an improvement?

Have you tried setting the RME driver with a lower buffer? 2048 seems kinda high.

It’s worse with a lower buffer.

7.5 is bloated and I don’t know why. 64bit or 32bit, makes no difference. I’m on a 32 bit system and so far I’m running a little hot(50-65%) and on cubase 5 it was minimal. A lot of people tell me to go 64bit but I keep seeing the same thing over and over…I’m on 64bit and asio is high. 64bit at this point is great for running a lot of plugins that are pigs on the graphics. I’m old school so I don’t mind freezing and bouncing down tracks. I actually prefer it since I do it anyway for the final mix.

Hmmm. Weird. Does your RME have an “optimization/reduce CPU/stability” setting within the device itself, by any chance? The reason is ask, is that with my (crappier) roland q. capture, this option actually made things much much worse in C7.5, and other DAW’s as well. Just a stab in the dark here…