VST Playback delay

I’m trying to set the VST internal sounds to play instantly when I push a note on my external keyboard, and not with a delay as it is now. I have a presonus audiobox connecting it. Do you know any way to set the cubase to play the virtual instrument instantly? It would really help.

Thank you

Do you have a soundcard with good ie latest drivers?

As Buchanan says it is mostly a function of your sound card buffer settings.
The whole issue of latency is very core and basic to using any DAW or Computer based audio stuff.
RTFM, in other words.

But - 3 factors:

  1. You sound card latency. You need to set your buffers as low as possible keeping in mind the lower the more CPU intensive and possibility of playback issues.
  2. The VSTi’s latency. Minor usually and only sometimes changeable.
  3. Any plugins you’re using in your project anywhere that introduce latency. Cubase will compensate for this and delay EVERYTHING accordingly so it is all in time.
    By activating “Constrain Delay Compensation” these plugs will be temporarily deactivated. You can find this in the manual.

Good Luck!


Please just RTM will do. I get told off for less and threatened with banning. Just saying.

Thanks. I’ll keep that in mind.
Just trying to be . . uh . . helpful and suggestive.

sounds like you dont have asio driver selected in device settings