VST Quick Control loses focus when assignment is changed

If I change the assignment for one of the Quick Controls of an instrument, the instrument loses its focus and I have to click on it again to use it. I find this behaviour very strange. If I change the assignment of a Quick Control, I obviously want keep working on it. This must surely be a bug? I’m on Cubase 13.0.20 and Mac Ventura 13.6.3

1 Like

Hi,

Do you use the Quick Controls or the Focus Quick Controls, please?

The focus quick controls

Hi,

The Focus Quick Controls are based on the focus. So if the plug-in is not in focus anymore, the controls are not moving anymore.

I understand that, but why does the instrument lose its focus when i change its focus quick control assignment?

Hi,

How exactly do you do the assignment, please?

I open the focus quick control area by clicking the QC button and choose a new assignment from the drop down menu from one on the QC slots. This leads to the instrument losing its focus.

I just checked on Cubase 12. There, the plugin loses focus when the list of parameters is open. As soon as a parameter is chosen the plugin regains focus.

1 Like

This is how I expected it to work. Can anyone else check on their system with cubase 13?

This might be helpful:

Thank you. It’s a workaround, but it shouldn’t be necessary in this scenario.

If I’m honest l don’t fully understand the difference or a better word would be the ‘point’ of the focus quick controls and the selected track QC (and then there’s the ‘normal’QC too).
I know what the manual says, and that you can lock the focus ones , but like you say, the focus QC ironically lose focus
All the time. When would we be wanting to use a QC and
Not have it in focus? I don’t get it.
It’s also a shame we can’t control the ‘L’ (Learn) button too. ,
If he could that would make how i go about it a bit different I think -

Hi,

I have just tested this and it works as expected for me.

  • Assign any encoder to the Focus Quick Control 1.
  • Add an Audio Track, add a plug-in and open the GUI of the plug-in.
  • Open the Focus Quick Control Panel.
  • Move the encoder assigned to the Focus Quick Control 1.
    => The automatically assigned parameter is moving as expected.
  • Click on the parameter name in the Focus Quick Control section and change the assigned parameter.
  • Move the encoder assigned to the Focus Quick Control 1.
    => The automatically assigned parameter is moving as expected.

Am I missing something?

It’s instrument I have trouble with. Try the same with a VST instrument, please. If I change a parameter of one of the Focus Quick Controls the focus shifts to the Track Quick Controls.

1 Like

Hi,

You are right. I can reproduce it with an Instrument.

Reported to Steinberg. Thank you.

1 Like

Hello

I have same behavior with audio track.
Cubase 13.0.20, macOS Ventura 13.6.4