VST Real-Time Peak performance varies on track selection

This is something I noticed in C8.5 but also carries over to C9. The following problem exists in both versions.

I’ve optimized my system to increase maximum Real-Time latency performance, yet when a reasonable amount of plugs are used, the real-time peak meter starts slamming and creating dropouts etc.

But the problem only exists if an Instrument track (also Sampler track in C9) is selected. See attached pics… these are from the same project and it makes no difference if the song is playing or not. The only difference between the 2 pics is that where the meter is slamming an instrument track is selected and active.

Again just to clarify, the project plays just dandy if an instrument track isn’t selected, even with instrument tracks playing. But as soon as you select an instrument track… even if the song is stopped… SLAMMO on the Real-Time peak meter.

Any ideas on this? Could this be nothing more than the result of a specific preferences setting I haven’t thought of?

Graham
Non-Instrument track.JPG
Instrument track.JPG

Hi,

This is expected. By default, Cubase enable Record on the selected track. So the track is processed different way, because Cubase expects you will record some data (so play back the data in the real time). This is the reason.

If you disable Record on the track manually, or if you disable the Preferences, the Real-Time Peak will not go up, when you select the track.

That would be the asio guard working it’s magic

Selected tracks are always calculated in real time and ASIO guard doesn’t work on them.

Exactly!

Not always… If you switch the mentioned Preferences Off, then there is no need.

Might be the retrospective record.

If you are using Cubase’s ability to background record on selected tracks even when not recording from the transport, you will have a performance hit when that instrument track is selected.
Command/Ctrl * will dump out the buffered midi (see the Op Manual for more info on Retrospective Record)
You can find this setting in Preferences -> Record -> MIDI -> Retrospective Record

Try disabling it and see if your issue persists.

Interesting idea… I soulad say, Cunase caltures just the raw MIDI data, and you can “paste” it where ever you want to later. I would be surprised, if the VSTi is taken in account here.

But might be, I’m wrong.