VST Sound Library "" not found

I receive an error when I load HALion 6 in Cubase 8.5.20 and 9.0.10 (Windows 10 x64). The error says: ‘VST Sound Library “” not found:’ and then it lists the location of the library it is looking for. The blank quote marks ("") are in the error message, as shown. There are three option buttons: LOCATE, IGNORE, and REMOVE.

When I select LOCATE and click on the file in question, it just asks me for the same file over and over again. Nevertheless, HALion 6 loads.

This also occurs with Padshop Pro (x64).

Please advise if you have an idea.

Same thing happens with me when starting cubase 9

I have the same problem.
Even with the groove agent 4 and loading production kits.

Bad installers from Steinberg. :neutral_face:

Hi there,

I have the same problem with Hal 6 as the OP.

Did anyone find the solution please?

Kind regards, Codsworth

I was getting this with Hypnotic Dance but I checked and I have the 300 presets as advertised so it must be an error. It is looking for a group of presets that doesn’t exist. So just remove the reference from the library and it will stop looking for the file.

You get this once you have removed a library.
Looks like a combination of what cubase is saving with the cpr (which is not the actual vstsound but some copy of it it seems)
Once removed and you load a cpr that has references to an old deleted file it continues to look for the thing that was removed.
By the way, the library handling with H6 has become a real PITA.
With all those extreme naming and referencing conditions that have to be fulfilled it just gets more and more cluttered on the harddrive.
This is something that definitly has to be improved in the next update, since it is not even possible to make a very simple sound working in HS3 as it should. It did once, but then things got completely messed up…

I have same issue.

First, always try updating eLicenser. Even if it’s the latest version, go ahead and download a fresh copy and reinstall. Run the cleanup process. Over time I’ve learned to start here anytime something Steinberg acts up, particularly after installing new Steinberg software or updates.

In testing, I install and uninstall lots of things Halion related, and more often than not, reinstalling and cleaning up eLicenser clears things up for me.

If that doesn’t work, read on:

I got this at one point, but tracked it down to what seems to be this:

I had downloaded some User made content packs (found here) individually at some point. I unzipped them to a location (“C:\Samples\Halion\VSTsound”).

The catch seems to be that I’d asked the MediaBay in Cubase to keep a continuous scan for any samples and other content stored in “C:\Samples”.

I’d installed it with the Halion Library Manger, which also put a fresh copy (I’d asked it to copy rather than move) into the usual “ProgramData\Steinberg\Content\VSTsound” directory that Halion likes to keep things.

I kept getting the popups after doing this, even if I used the Library manager to unregister, and delete the said content from “ProgramData\Steinberg\Content\VSTsound”.

So I figured, Halion must still be asking for this content for a reason…but why?

At some point it hit me, “I wonder what would happen if I move this vstsound archive that I’ve kept lingering in “C:\Samples” to a directory that is NOT set to be scanned by the Cubase Media Bay for content?”

I checked the Media Bay in Cubase, and as suspected, I had toggled this directory for continuous scanning of potential content, since I often keep lots of wav/aiff, and other shorter sample content stored there and like to have it bagged, tagged, and preview ready in Media Bay. In the past I’d also kept some vstsound archives in here that I often got samples from to build with in Halion 5, but didn’t have any important ‘Halion presets’ stored in…so I’d simply been treating them like MediaBay browseable sample containers.

So, I moved the fresh archive that seemed to be causing trouble to a location that doesn’t get scanned, and the pop-ups went away.

I reinstalled those user content packs with the Librarian, and they worked as expected, plus, no more popups.

The point is, if you’ve got extra copies of some vstsound archives lurking somewhere, make sure that you do not keep such extraneous copies in a directory that Halion and/or Cubase keeps scanned for content. If you’ve not installed anything out of ordinary on your own using the Library Manager, it still might be that the directory where you downloaded and installed Halion 6 or Sonic 3 from, happens to be in a directory that gets scanned for MediaBay on a regular basis. If so, try moving your installer directories (any installers that contain unpacked vstsound files) elsewhere (I.E. “C:\InstallerScreenTank”) and see if that clears things up.

The new Library Manager allows us to register content from any location we like. When double clicking on a *.vstsound archive, it scans all vstsound files in the same directory and if they are not already installed we get some options.

If we tell it to ‘move’ the content when registering, it moves the whole file to “ProgramData\Steinberg\Content\VSTsound” and registers it.

If we tell it to ‘copy’ the content, it makes a ‘copy’ of the vstsound archives to “ProgramData\Steinberg\Content\VSTsound” and registers them.

If we let it install from the present location, it keeps the VSTSound file where you launched Library Manger from, and puts a ‘shortcut’ pointing to the current location in “ProgramData\Steinberg\Content\VSTsound”.

One potential catch here is that many Cubase Users may well have MediaBay settings that keep a scan of any potential content in their “%USERPROFILE%” directory, and that happens to include your “Download” and “Document” directories, as well as anything kept ‘on your Desktop’! Those are all pretty common places for people to unpack and launch their installers and libraries from. Are they getting ‘double scanned’ when Halion launches?

With all that in mind…
My short guess is this:

Problem: If Halion comes across a second copy of the same VSTsound (perhaps shortcuts count as well) when it’s loading, it causes a fuss. One copy may be properly registered while the other is not, or perhaps there can also be cases where neither is registered…and Halion gets confused in the process so he asks you for intervention (ignore worked for me in the shorthaul).

Solution: Make sure any extra copies of VSTsound content are kept somewhere that doesn’t regularly get scanned by MediaBay for potential content. I.E. Zip it and get rid of the unzipped backup, or move it someplace that MediaBay ignores. In short, take care that Halion doesn’t try to scan the same vstsound archive twice when it starts up.

The good news, at least for me, is that even if I forget and mess up, tapping ignore during the plugin load will let me work without issues until I can get around to finding and moving/removing the lingering vstsound file.

This seems like a bug to me…

Bumping an old thread. This has just happened to me. Cubase 8.5 was working flawlessly until PC crashed and all vst programmes reinitialized. Any solutions?? Thanks.

Hi guys,

Same thing happened to me, as a user of Symphonic Orchestra (vst only), which used Sonic SE built in installer and one month ago elicencer stopped authorizing this VST. I called a support guy and we figured out that I should update to “visible” installation od Sonic 3 SE. And then. … happened the same thing which is VST sound library not found" and it loads empty inner windows in Symphonic Orchestra. Any additional ideas for me? I will try to this method you mentioned , but maybe you got some other solutions yet? fcp_smt_027_hso_presets_01.vstsound is missing, and it’s not on my HDD at all or even in HSO installer :confused:

I got same error message and I clicked “remove” -but now each time Cubase 9.5.21 starts, it scans all the vstsound folders! It takes 4-5minutes lol

That happened after a PC crash.

I’ll try to reinstall e-licenser and come back…

EDIT: No luck…still loading vstsounds …
I tried to install again latest Cubase update… no luck still

I believe it is related to 9.5.21 latest upgrade…buggy as hell

same here 9.0.40 after PC crash.

does someone find solution ?

Reseting de Steinberg’s Appdata folder by deleting or renaming it (which is preferable)… and run Cubase again to rebuild the default one.
Or, if y’r feeling yourself nerdy, you can try renaming all the files step by step to see which one occurs the “VST Sound Library “” not found” error… or you can still ask the amazing & prestigious steinberg’s team :nerd:

Fixed the missing Halion Sonic 3 errors in my case.
In Windows 10 :

  • Close Cubase if it is open
  • Press the start button and type %appdata% to go to the current user Appdata folder
  • Open Roaming > Steinberg
  • Select all the folders containing “Halion Sonic” CUT and PASTE them in another folder (NOT inside the same Steinberg folder) this way you will not lose the other preferences stored in the Steinberg folder (shortcuts, colors, recent files, all settings etc.)
  • Restart Cubase
  • Create an Instrument Track with Halion Sonic SE 3 and you should have all the 124 default preset back without errors


this is how i fixed the same problem (VST Sound Library “” not found) after Win10-Crash :cry: (a reinstall of all Cubase-Stuff didn’t fix it)

  • close Cubase
  • rename the folder called somewhat like appdata/Roaming/Steinberg/Cubase 9.5_64 to e.g. “**1_**Cubase 9.5_64”
  • Start Cubase. Load last .cpr I worked on. Got weired errors for missing Native Instruments PlugIns. Don’t care about errors.
  • Close Cubase (without saving yout Project)
  • In the new created folder Cubase 9.5_64 there’s also a new file called “ContentManager”. Copy this file into old folder “**1_**Cubase 9.5_64” (overwrite)
  • delete the new createt Cubase 9.5_64 folder an re-rename your original folder"**1_**Cubase 9.5_64" to the original name “Cubase 9.5_64”
  • Start Cubase -> no error , all old preferences :slight_smile:

    This works for me
    Rock on…

I got this after an update. For me, running maintenance tasks in the elicencer control center fixed it.

Super frustrated here.
Just downloaded the HS 3 installer and separate content using the Steinberg Download Manager then installed the Application then ran the library manager.
The library manager is not finding the content and is not asking me register anything. Installing on mac is so much easier.
Where should I place the Content for HS 3?

Halion gives me the same things every time i start it.
You have the option to IGNORE, but next time start, it reports the same, and i IGNORE again.
It is only one file and it gets stuck on it…

:smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:

The latest update Halion 6.3 fixed this with me…

:laughing: :laughing: :laughing: :laughing: :laughing: