VST window disappears when focus moves to 2nd monitor

Hi

I have 2 monitors.
Cubase main application windows on monitor no. 1, with a VST window on top (with always on top enabled).
I’m watching a tutorial video on monitor no. 2, teaching me about the VST on monitor 1.
As soon as the focus moves to the monitor no. 2 (e.g. because I want to rewind the yt video by a few seconds), the VST window disappears from monitor no. 2!
Only when I click again on monitor no. 1, now showing Cubase but WITHOUT the VST window, does the VST suddenly re-appear.

Why is this happening, and how can I stop it? It’s maddening.

Thanks.

I use two monitors as well, qba55. I like watching Cubase or other instructional videos with VST windows open and sure enough, as soon as you move the focus to the second monitor, the first monitor’s so-called “always on top” windows close and remain closed. PITA!!!

I believe the “window always on top” is only a partial solution that is designed for single monitor usage and is an offshoot of Steinberg not recognizing that some people use more than one monitor. For a window to stay fully open no matter what, the window must be classified as “non-modal.” I’m not sure how that’s done nor do I have an answer for you. Sorry…:frowning:.

Actually the trick is to turn off the Always on Top.

When AOT is enabled the Widow is seen as a ‘child’ (sorry don’t know the proper Windows term) of the main Cubase Window, much the same as a Window that opens for file selection might be. Any window like this will disappear when the focus shifts to a different program. The problem you are seeing is not related to the 2nd monitor. It is caused because the focus has shifted to another program - probably the browser you are watching the video in. But if you turn off AOT then it becomes just like a normal Windows window - it will even have its own tab on the W10 taskbar. Of course now it can also be hidden behind another window - just like regular windows. But it also will not disappear when you shift focus to another program. Just make sure to move it to someplace that won’t get hidden by another window. And if it is behind another window you can click on it’s Taskbar Tab to bring it to the front.

1 Like

Can confirm, switch off Always On Top, it’s for one monitor setup and also small plugins. With huge Cubase plugins like nowadays, it’s inconvenient.
Also there is option in Key Preferences to switch between plugin windows and close all plugins windows, also you can open all VST-FX by clicking Alt + Shift + Edit(edit icon)

Thanks, Roger. I’ll have to give that a try. It defies the logic behind the message “Always on top” but I’ve never thought coders were in touch with the real world.