VST Windows disappear when attempting to drag&drop files from the Windows Explorer

No open VST re-appear when I drag something of the File Explorer back to a particular VST window.
I have to Click on one of the Cubase windows (e.g. Project or Mixer window) but that was not the window where I want to drop my file. The VST windows do not re-appear when I hover over such a window, I explicitly have to click Cubase itself and then the VST windows re-appear. The only thing to drag something on a VST is by the old fashioned Ctrl-C and Ctrl-V method which is very inconvenient.

Why on the first place must the open VST windows disappear when you click outside Cubase. This is not normal Windows or even Apple behaviour. Please do let the VST windows open as expected.

I have moved your message to a new thread and will get back to you soon.

For some mysterious reason, Steinberg has decided to hide the VST windows (when some other application has focus) if they are set to be “Always on top”.

If you remove the “Always on top” setting from your VST, it will stay on top(!) even when, e.g., your File Explorer has focus, so you can drag/drop your files.

So there is your statement Steinberg does its own way of programming Windows behavior for whatever reason (probably has something to do with protecting their environment) and makes it so inconvenient for users. They should (re)program it or give the user more options to choose from in that area a lot of work to do.

Take a good look at Cakewalk by Bandlab, how they give the user options for VST’s! It is that I can not use particular VSTs of Cubase internal and settings inside Cakewalk else I switched totally for all of my music or music setups to that platform.

By the way it is a fable that you can not resize VST windows when they are VST2. Many VST2 plugins are resizable and are aware when using HiDPI.

There is a workaround for Windows: briefly hovering with the mouse pointer on the taskbar icon - this will bring back focus to Cubase and the plugins will re-appear on top of the application.

On Mac, briefly keeping the mouse pointer on the application will bring the focus back.

Hovering over does not work, you have to click on the icon or click on the open Cubase platform.
Again I must say this is a Steinberg only behaviour and probably discussed a lot and it won’t be changed. So as many request, close this call and do nothing. Steinberg has reasons for not listening to their users and the only reason that I can think of is protecting the Steinberg World.

Since you make this assertion, I’ll mention that what you surmise is based on your own thoughts, which does not include actual information on the subject.

The workaround for this is entirely trivial (turn off Always on Top).

You can make a feature request, but I have a feeling based on the tone of your posts it’s not something you would do.