vst3 problems

on KVR, robin has also reacted, to the problems with the vst3 implementation.

i didn’t try it yet, was busy with the better editing, already great results. the playback, with frequency range, simple but great.

on topic:

tried first a waves plugin, because the shellss, trueverb, worked.

then softube tsar-1 (the biggy), preview does not work, and the spectral display of the selection/layer disappears, i.e. the visualisation, as the sound.
also with for example brainworx digital V3, or IK multimedia CSR plate. same problem. applying, only keeps one small portion of the sound, i.e. almost all is gone…

didn’t try other plugins, too many, to check… but it seems a common problem… if more info is needed…

Hi Howl, was it in ARA mode or stand-alone mode ?
After testing Softube TSAR-1 and TSAR-1R and IK Multimedia CSR Plate in the stand-alone SL7 on Windows 10 on both mono and stereo file I couldn’t repro your issue.

stand alone. on a layer. specs are in my signature. windows fully up to date. latest studio drivers (only drivers) for nvidia.


in standalone. opened project. the layer was already soloed.
indeed no problems with tsar-1.
then loaded trueverb no problems.
then loaded brainworx digital v3.

preview/bypass, etc. when i loaded these plugins. all worked.

then tsar-1 again: the problem reoccurs.

so the problem seems to be: load different plugins after eachother, perhaps if you don’t use preview or bypass, it will work endlessy…
but at some time the problem occurs.


thanks for your fast response, i already suspected that it has to do, with loading or changing plugins. or when you also use preview. some cache, some pointer (…), it seems to be cumulative before the error occurs…


now i can’t reproduce it again, strangely. but after trying, melda, softube, arturia, etc. many plugins… spectralayers crashed…

EDIT: PM with crash file, dmp file sent.

Thanks for the detailed explanation, I was able to repro and identify the issue. Now fixed, it will be in the patch coming early next week.

More VST3 issues:

  1. Resizing does not work properly, tested with TBProAudio dpMeter4 and FabFilter Pro Q2
  2. Plugin does not hold parameter set after closing vst3 dialog

Spec: SL7 Pro, Win10, Standalone

thanks! it is somewhat erratic when it happens, i mean to reproduce it, it is not always the same, glad you could reproduce it. and the fix, fast! thanks again.

Any feedback on this one?
Thank you.

Edit: OK I saw the change log of the upcoming patch. I will report if it is OK then :wink: