VSTAudioEngine5.exe is unkillable process

Lately, every other time or so I close Dorico, VSTAudioEngine5.exe hangs and cannot be killed by any means other than restarting the computer. I see other threads here where Dorico has crashed and orphaned the process, but in all of my cases, Dorico appeared to terminate cleanly.

If I try to kill it through Task Manager as usual, I get an Access Denied error. If I try with taskkill /im VSTAudioEngine5.exe /f, it tells me that there is no running instance of the task. Pskill claims to kill the process but in actuality it does not. Process Hacker’s Terminator feature doesn’t make a dent. Even if I run cmd as the nt authority\system user, I cannot kill the process.

It seems to be running one thread with a start address of nvwgf2umx.dll!NVDEV_Thunk+0x610n64 – does this indicate some sort of compatibility issue with NVIDIA graphics cards?

As I said earlier, my only recourse currently seems to be restarting the computer, but given the frequency with which this happens, I’m really hoping we can come to some other conclusion here.

1 Like

You’ll need to post a Diagnostic Report.

Hi @JustinM , posting a diagnostics report, as benwiggy proposes, is always a good starting point. Therefore do from the menu ‘Help > Create Diagnostics Report’ and post the corresponding zip file here.

Second, what if you run TaskManager as administrator and from there try to kill the audio engine process?

How to do:

  • Press Win + S keys to open the Search box, and then type task manager in it.
  • Right-click the Task Manager app from the best match and select Run as administrator.

I’ll try to recreate the issue, but when it is in that state, I can’t open Dorico, so I can’t run a diagnostic report. Here’s one from a clean open just now, don’t know whether that’s of any use.

Yes, I’ve tried running Task Manager as administrator, just forgot to mention it in the OP. Don’t be afraid to be as technical with me as you want or need to be; my day job for the last 17 years has been in IT.

Dorico Diagnostics.zip (1.1 MB)

Hi @JustinM , thanks for the diagnostics.
I am really surprised to see the audio engine logs. Always the logs of the last 10 runs are kept, and looking at them, I always see the same, a properly shutting down VSTAudioEngine process, at least that is what the logs let me believe, unless something is happening in the very very last second of a run.
Can you reproduce the issue at will, is it happening every time?
If you have the issue again, please have a look if there is maybe a modal dialog box hidden behind the Dorico window?

Hi Ulf,

I cannot reproduce it at will. I’m sure it’s not completely random, but I haven’t figured out a pattern yet. I thought that it might be coming from closing Dorico before closing NotePerformer Playback Engines, but that is definitely not the case because I’ve been closing NPPE first consistently since I thought of that possibility and it still happened.

The only dialog I get is the “audio engine is taking longer than expeected to respond” as is usual for this situation. This did, however, create a diagnostic report all its own, so I’ll go ahead and attach it here. It looks like another disappointing result, though, if I’m looking at the correct log.

Dorico Diagnostics.zip (1.3 MB)

Running Windows 11 Insider Preview by any chance?

It’s ever so slightly wobbly with things I have found.

Hi Justin, thanks for the data. There are no crash dumps contained, nor anything else unusual. Also the logs of the last 10 runs show nothing unusual. Every run finished with the audio engine shutting down properly and as expected.

May I ask you then to download Process Explorer , it’s like TaskManager only far more better and reliable.
With Process Explorer you can also kill processes, does that maybe work better than others? Anyway, with PE you can also create mini dumps. So if Dorico is hanging, then look for the VSTAudioEngine process, do a right click on it and from the pop-up menu choose ‘Create > Create mini dump’. Do that 3 times in a row and then please send me the corresponding dump files. Thank you very much.

I probably shouldn’t contribute as @Ulf knows WAY more about this than me, but I was curious. I could not see what OS you are using from the logs, and I noticed you have a MOTU M USB audio device. Do you have another different USB interface you could try? USB interface drivers up to date? Any known incompatibility issues?

I also notice the logs show references to Admin in the AppData area. Is that a good idea, to run as admin? Perhaps not - is it you can’t kill the audio engine as it is therefore possibly running with some sort of higher permissions?

Pardon me if this is just noise.

@Andro, no noise at all, certainly pertinent what you write. Though, it’s the first time that I hear an audio engine process can not be killed. And I doubt that is has something to do with the driver, but you never know, so it is worth considering a driver update or a different interface.
Your second point is even more relevant. I did not see the references to Admin in the logs, but will check again. That is suspicious.
So in the end, thank you Andro.

@Ulf also knows better than me, but maybe a batch has more privileges so try:
Create a txt file and write it on inside:
TSKILL VSTAudioEngine5
then save and change the extension in .bat and double click on this file

Hi @Dup, right, one can do that with a batch file, but then you also need to run that one in administrator mode (i.e. run a cmd window as admin and from there invoke the batch file.

Running a batch as administrator uses the same level of token as running cmd as administrator and doing taskkill (or psexec, or any other tool) from there. Considering that NT AUTHORITY\SYSTEM cannot kill the process, there isn’t a permission level in the world that will do the trick.

Sorry for the multiple replies in a row, not sure how to multiquote here.

Admin is just a generic username I set the computer up with. Nothing to see there. :wink:

Hi @JustinM , but there must be something differently set up on your machine, if the audio engine is unkillable. I can’t recall having had such a case before.

While googling on this, what if you add /T as option to the taskkill command? That one is supposed to kill all child processes as well.

I also never had the problem of not being able to kill a process.

Whenever a process is complaining that I do not have permission I use ProcessExplorer and select the menu item shown in this screenshot

image

That asks for Admin permissions and after that I can kill all processes shown in the list. Maybe that is an easier option than fiddling with the cmd tool in Windows.

So why is your installation referencing Admin in the AppData area?

Have you installed Dorico as Administrator? I have a feeling that is a bad idea. Instead of hacking process termination, we need to find the root cause, of course.

I did some more googling and found an interesting article which describes why it can happen that processes are unkillable: Unkillable Processes - Microsoft Community Hub

Unfortunately it is only a description, but there is no definite solution. On the other hand, reading that article, your problem could really come from that thread with nvwgf2umx.dll. So make sure that you have an up to date NVidia driver.

Latest Nvidia is 551.23 released on 1/24/2024.

Use Geforce experience to check and update.

Observe this:

The cause is usually some unresponsive driver which has unfinished I/O requests in progress.

That can happen on Linux also.