VSTi Latency on bigger project What am I missing?

I usually work with audio tracks with maybe one or two midi tracks but now I’m doing a project that’s mostly midi (6 Vsti’s) and now that the project is growing and I can’t get the latency down even though I’m at 128 samples on my RME HDSP 9652. This is a fairly fresh install of Windows 10 and Cubase 8.5 with mostly stock settings.

I noticed when I play the keyboard the note is late but it still shows up on time in the editor but it’s impossible to lay anything down. I did import a two track mix mix and opened a blank project and was able to work on additional parts but I’d rather do it all in the same project.

Can anyone point me to what might be wrong? Is it a setting? It’s been a long time since I’ve done a VSTi project this big so latency hasn’t been an issue for a long time