VSTi recording latency

I’m having problems recording through a VSTi such as the Halion bundled with Cubase LE4. I’ve tried another VSTi (GSi VB3) and experienced the same problem.

I’m using Cubase LE4 (latest version) with a TC Electronic Desktop Konnekt 6 interface, and I’m recording using a guitar synth.

I first noticed the problem after I had laid down a drum track and then played a piano part on top. While I was tracking I could monitor the drum track and what I was playing on the ‘piano’ without any issues. However, when I played back the two tracks together, they were totally out of time with each other.

I’ve down a wee bit more testing, and I’ve tried changing some settings, but not had any success yet.

What I’ve seen is that when tracking, if I play a note at the start of a bar I hear it ‘immediately’, so there’s no problem monitoring when tracking. However, I see that the midi information isn’t written to the track until 1 or 2 beats further down the track. It means that track doesn’t line up with any existing tracks. Audio tacks record without any problems.

It’s probably (hopefully!) a simple tweak, but as I say I’ve not stumbled upon the fix. Any help would be much appreciated.


Use the Emulated Ports for the MIDI controller. Look up enableemulated in the manual. This is for PC only.

Thanks for that, MashedMitten – it seems to be working now.

By the way, I couldn’t see any sign of ‘enableemulated’ in the manual, but I found some instructions by doing a web search.

Might be under Port Filter. Anyways, at least you’re sorted.

I have just run into a similar problem, like i have switched something stupid on and got a MAJOR midi latency when trying to record, even though I am not hearing any latency when playing. I recorded an audio track with no problem but I just went to record a bass part using halion one and its not showing in the track until a few seconds after its being played---- i have never had such a latency in my life, even using none pro gear, this is WAY too much. Audio is recording fine, midi is playing fine -the track meter is in real time with the midi sound coming out but the actual note info isnt getting to the track till much later when i hit record - like a bar and a half after. Is there something stupid I may have done (dont remember doing any changes in the prefs or anything) My gear hasn’t changed, only thing i did recently was update cubase 5.5.3 build 651 - but it seems this has just kicked in now as I didnt notice it before. Does anyone have any idea? EMU1616m - intel core duo 5600 - 2gb ram…done tonnes of glitch free recording on this up till now.

Correct ASIO driver selected?

EMU ASIO selected… I may have sorted it though I don’t know why…I changed from my normal 4ms to a long latency (100ms) in the EMU control panel and back to my normal 4ms and it seems to have cleared - bizzare but its working ok for now…I’ll never understand how these random glitches can so uspset the day and the workflow…thanks for the quick read ad response BTW.